Bug 154356 - Boot hangs if eth0 configured on install with DHCP enabled
Boot hangs if eth0 configured on install with DHCP enabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-10 17:29 EDT by David W. Myers
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 10:18:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David W. Myers 2005-04-10 17:29:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90; .NET CLR 1.1.4322)

Description of problem:
The system hangs on first boot if Fedora Core 3 installed with DHCP selected.

Version-Release number of selected component (if applicable):
More than one version shows this issue.

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 3. Select DHCP on installation.
2. Boot server.
  

Actual Results:  System boots to the point it attempts to bring up eth0 and it hangs hard. Nothing works to regain control but a hard reset of system.

Expected Results:  Either DHCP should have worked or this subsystem should have failed and system brought up to run level 5 with networking disabled.

Additional info:

This problem is also seen in Fedora Core 2.
This problem is -not- seen in Fedora Core 1.
This problem is -not- seen in Fedora Core 4, test 1 (though RH4t1 has display issues).
RH9 does not recognize onboard ethernet, boots ok.

Related BZ problems are 123053 and 111683. Thing is, I observe no problems with FC1 at all. My problems are not cured by manual start of eth0 (hence different from 111683).

motherboard is Asus AV78X, DHCP source is Netgear RP614 router. System is connected to internet (cable) with Netlink router. Win XP works fine on this system, as does Fedora Core 1 (usually configured as a dual boot Win/Linux).
Comment 1 Jason Vas Dias 2005-04-10 18:09:24 EDT
Please supply some additional information to enable resolution of this bug:
Are you running under VMWare ?
Does your /etc/sysconfig/network-scripts/ifcfg-eth0 file contain a 
   GATEWAY=...
setting ? If so, removing it should help.
If you have no GATEWAY setting, but still experience the problem, please
do the following:
1. Boot into single-user mode (supply -s boot option in the grub menu)
2. From the single-user mode command line:
   # ifup lo
   # ifconfig eth0 0.0.0.0 up
   # tcpdump -nl -vvv -i eth0 -s 2048 port bootpc or port bootps \
     >/tmp/tcpdump.log 2>&1
   # dhclient -1 eth0 2>&1 | tee /tmp/dhclient.log
3. When the problem occurs and dhclient has timed out for a while, 
   press CTRL+C, and then 
   # pkill tcpdump
   and append the /tmp/tcpdump.log and /tmp/dhclient.log to this bug report.
Thank You!
Comment 2 David W. Myers 2005-04-10 20:28:03 EDT
* Not running under VMWare.
* No GATEWAY statement in the file.
The ethernet controller is ASUSTek/Broadcom 440x 10/100 Integrated Controller.

---- dhclient.log ----
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:e0:18:e2:ed:f9
Sending on   LPF/eth0/00:e0:18:e2:ed:f9
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
---- end dhclient.log ----
---- tcpdump.log ----
tcpdump: WARNING: eth0: no IPv4 address assigned
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 2048 
bytes
20:13:51.001207 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, flags: [none] 
(0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
20:13:58.001140 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, secs:7, flags: 
[none] (0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
20:14:13.000864 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, secs:22, flags: 
[none] (0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
20:14:31.001125 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, secs:40, flags: 
[none] (0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
20:14:38.001053 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, secs:47, flags: 
[none] (0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
20:14:45.000993 IP (tos 0x10, ttl  16, id 0, offset 0, flags [none], proto 17, 
length: 328) 0.0.0.0.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, 
Request from 00:e0:18:e2:ed:f9, length: 300, xid:0x8e95e37a, secs:54, flags: 
[none] (0x0000)
	  Client Ethernet Address: 00:e0:18:e2:ed:f9
	  Vendor-rfc1048:
	    DHCP:DISCOVER
	    PR:SM+BR+TZ+DG+DN+NS+HN+YD+YS+NTP
---- end tcpdump.log ----
Comment 3 Jason Vas Dias 2005-04-11 10:44:00 EDT
Thanks for the information.

It seems that your DHCP client is sending standard DHCPREQUESTs, 
but receives no responses to them.

Since the test was run in single-user mode (init state 1), 
the iptables service will be stopped and we can rule out
firewall rules misconfiguration.

Because no previous lease had been obtained, dhclient has no
IP address to fall back to, and cannot configure the interface
in the absence of a response from the DHCP server, so no IP 
address will be obtained.

Check connectivity with the DHCP server - if you know its
address, try configuring the interface with a static IP
address manually and pinging the server.

If configuration with a static IP address and pinging the
server fails, try pinging any host known to be active on 
the local network. 
If this also fails, then it would appear you have a problem
with either the ethernet card hardware or driver. If the
card works under a different operating system, then this
would appear to be a kernel issue - please move this bug
to the kernel.

As you can see, in the event of an unreachable DHCP server,
dhclient by default times out within 1 minute. 

The time-outs that hold up the boot sequence are likely to be
host name lookups. By default, the resolver library times out
for around 5 minutes per request . You can adjust this by 
setting the 'timeout:n attempts:n' options in /etc/resolv.conf -
these are preserved across settings of the nameserver and search
options .  I use these settings in /etc/resolv.conf:
  "options attempts:2 timeout:2
  "











Comment 4 David W. Myers 2005-04-12 00:51:00 EDT
I did configure the ethernet card for static IP (I set up my DHCP to give out 
the same address to all machines on my network) so I set it to the typical IP 
and tried to ping anything. Nothing worked. So, as you suggest, this should be 
turned over to the kernel group (I don't seem capable of that with my current 
access..).

I'm tempted (after trying a FC4 test 2 install) to reinstalling FC3 and 
attempting to wget the 2.6-10 kernel.. people seem to be doing that a lot to 
fix ethernet issues.
Comment 5 Jason Vas Dias 2005-04-12 11:01:14 EDT
You say:
"
(I set up my DHCP to give out the same address to all machines on my network)
"
Surely you don't mean that more than one host on the network has the same IP
address ? This is a bad idea, and would mean that ping replies would not 
reach you.  Set the IP of the card statically to a known unique IP address
that is on the same subnet as another address on your local network .

eg. if you have a machine on the network with IP address 192.168.2.1, netmask 
255.255.255.0, and you know the address 192.168.2.2 is not in use, set the IP
of the card to 192.168.2.2 and try to ping 192.168.2.1.

You can determine if an address is in use as follows - eg. to determine 
if 192.168.2.2 is in use:
 1. boot into single user mode
 2. ifup lo
 3. ifconfig eth0 0.0.0.0 up
 4. arping -D -I eth0 192.168.2.2
 
If the arping produces a response, then 192.168.2.2 is in use
(and your ethernet card and driver are working).
  
Also try the arping to an IP address known to be in use, eg.
 # arping -D -I eth0 192.168.2.1

If you get no responses to any arping / ping command, then it
is most likely a kernel / driver bug or a defective ethernet
controller.
 
Please append the output of the commands:
  # lspci -vv
  # lsmod
  # cat /etc/modprobe.conf
to this bug, and I'll move this bug to the kernel.
Comment 6 David W. Myers 2005-04-12 20:43:08 EDT
Ack! what I meant was there are three devices on my network, the router 
(always has the address 192.168.0.1), a windows box (DHCP always gives it 
192.168.0.2) and the dual boot box (DHCP always gives it 192.168.0.3). I 
didn't mean to suggest they all had the same IP address as one another. I 
*meant* to suggest they are issued the same DHCP address on every boot. I 
apologise if I were unclear.

command output follows:

---- lspci -vv ----
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host 
Bridge
	Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort+ <MAbort+ >SERR- <PERR-
	Latency: 0
	Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [80] AGP version 3.5
		Status: RQ=32 Iso- ArqSz=0 Cal=2 SBA+ ITACoh- GART64- HTrans- 
64bit- FW- AGP3+ Rate=x4,x8
		Command: RQ=32 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- 
Rate=<none>
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge (prog-if 00 
[Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort+ >SERR- <PERR-
	Latency: 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: ee000000-efdfffff
	Prefetchable memory behind bridge: eff00000-f7ffffff
	Secondary status: 66Mhz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
 <MAbort- <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
	Capabilities: [80] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2- AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
	Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort+ <TAbort-
 <MAbort- >SERR- <PERR-
	Latency: 32
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at ed800000 (32-bit, non-prefetchable) [size=8K]
	Expansion ROM at efef0000 [disabled] [size=16K]
	Capabilities: [40] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME
(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=2 PME-

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. VT6202 USB2.0 4 port controller
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, Cache Line Size 08
	Interrupt: pin A routed to IRQ 3
	Region 4: I/O ports at d800 [size=32]
	Capabilities: [80] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME
(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. VT6202 USB2.0 4 port controller
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, Cache Line Size 08
	Interrupt: pin B routed to IRQ 3
	Region 4: I/O ports at d400 [size=32]
	Capabilities: [80] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME
(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. VT6202 USB2.0 4 port controller
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, Cache Line Size 08
	Interrupt: pin C routed to IRQ 3
	Region 4: I/O ports at d000 [size=32]
	Capabilities: [80] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME
(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) (prog-if 20 
[EHCI])
	Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, Cache Line Size 10
	Interrupt: pin D routed to IRQ 3
	Region 0: Memory at ed000000 (32-bit, non-prefetchable) [size=256]
	Capabilities: [80] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME
(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
	Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping+ SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 0
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:11.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) (prog-if 8a 
[Master SecP PriP])
	Subsystem: ASUSTeK Computer Inc. A7V8X motherboard
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32
	Interrupt: pin A routed to IRQ 255
	Region 4: I/O ports at b800 [size=16]
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 
AC97 Audio Controller (rev 50)
	Subsystem: ASUSTeK Computer Inc. A7V8X Motherboard (Realtek ALC650 
codec)
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Interrupt: pin C routed to IRQ 5
	Region 0: I/O ports at e000 [size=256]
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 
AGP 8x] (rev a1) (prog-if 00 [VGA])
	Subsystem: Micro-Star International Co., Ltd.: Unknown device 8943
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 64 (1250ns min, 250ns max)
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at ee000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at f0000000 (32-bit, prefetchable) [size=128M]
	Expansion ROM at effe0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-
,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [44] AGP version 3.0
		Status: RQ=32 Iso- ArqSz=0 Cal=3 SBA+ ITACoh- GART64- HTrans- 
64bit- FW+ AGP3+ Rate=x4,x8
		Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- 
Rate=<none>
---- end lspci ----



---- lsmod ----
Module                  Size  Used by
vfat                   14785  2 
fat                    45409  1 vfat
dm_mod                 54741  0 
button                  6481  0 
battery                 8517  0 
ac                      4805  0 
joydev                  8705  0 
uhci_hcd               31449  0 
ehci_hcd               31557  0 
snd_via82xx            27237  0 
snd_ac97_codec         64401  1 snd_via82xx
snd_pcm_oss            47609  0 
snd_mixer_oss          17217  1 snd_pcm_oss
snd_pcm                97993  2 snd_via82xx,snd_pcm_oss
snd_timer              29765  1 snd_pcm
snd_page_alloc          9673  2 snd_via82xx,snd_pcm
gameport                4801  1 snd_via82xx
snd_mpu401_uart         8769  1 snd_via82xx
snd_rawmidi            26725  1 snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    54053  9 
snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu4
01_uart,snd_rawmidi,snd_seq_device
soundcore               9889  1 snd
b44                    22213  0 
mii                     4673  1 b44
floppy                 58609  0 
ext3                  116809  4 
jbd                    74969  1 ext3
---- end lsmod ----



---- modprobe.conf ----
alias eth0 b44
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx 
&& /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 
|| : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
---- end modprobe.conf ----
Comment 7 Jason Vas Dias 2005-04-13 10:24:47 EDT
Thanks for all the information - sorry for the misunderstanding.

One last piece of information that would be most useful - in 
single-user mode, with interfaces down, please do:

# ( ethtool -d eth0; ethtool -i eth0; ethtool -e eth0; ) >/tmp/ethtool.log 2>&1
# ifconfig eth0 192.168.0.3 netmask 255.255.0.0 up
# arping -c2 -w2 -I eth0 -s 192.168.0.3 192.168.0.1 > /tmp/arping.log 2>&1 

and append the /tmp/ethtool.log and /tmp/arping log files to this bug .
 
Thank you!

Comment 8 John W. Linville 2005-05-25 16:27:30 EDT
Placing in NEEDINFO pending information requested in comment 7... 
Comment 9 John W. Linville 2005-06-27 10:17:31 EDT
Closed due to lack of response...please reopen if/when requested information 
becomes available... 

Note You need to log in before you can comment on or make changes to this bug.