This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 15438 - Sawfish doesn't remember window attributes correctly
Sawfish doesn't remember window attributes correctly
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-04 15:18 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 19:09:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-08-04 15:18:23 EDT
Sawfish doesn't place windows correctly when remembering positions.
Steps to reproduce:

Place new window on a different viewport and align it with a screen edge.
Log out and check "save current settings".
Log in again, and notice that the window has moved.

Sometimes, when trying to reproduce this, sawfish also forgets everything
alltogether and places all windows on the first viewport.
Comment 1 Mike A. Harris 2001-04-12 08:28:16 EDT
This might be the same as bug #19172 and bug #21732, or at least similar.
Comment 2 Mike A. Harris 2001-05-20 18:44:57 EDT
Yes, this happened to me in both GNOME and Enlightenment, however the problem
was slightly different in each.  I'm surprised this bug exists after this long
of me experiencing it, because I've noticed it on every install of GNOME since
it was initially released, and on every computer I've ever used GNOME on.
It is very reproduceable, especially when running applications like Netscape
or Mozilla fullscreen, and then opening a new window.

As much as I love GNOME, I tired of the problem, and switched to KDE in Seawolf
under Bero's advice.  I'm hoping that GNOME 1.4 fixes this problem as it is
too reproduceable and very bothersome.
Comment 3 Havoc Pennington 2001-05-20 19:09:53 EDT
Were you still on Sawfish 0.36 or have you tried 0.38 from 7.1.3?
Comment 4 Havoc Pennington 2001-07-12 13:53:21 EDT
Upstream as http://bugzilla.eazel.com/show_bug.cgi?id=8408

Closing in RH bugzilla
Comment 5 Mike A. Harris 2001-07-16 03:39:45 EDT
I was using stock sawfish, and then tried the one suggested in email to
no avail.  I also tried Enlightenment and it has the same problem indicating
that it is likely code shared between the two at the source level.

It was so frustrating to me to constantly be fighting GNOME that Bero
convinced me to try KDE and although I favor GNOME as a developer, I am
fairly desktop agnostic when I need to get work done.  As such I've switched
to KDE.  I'm going to try GNOME out with each beta, etc. but I'm sticking
with KDE until this bug is really fixed.  Unfortunately for us, it seems that
many people are switching to KDE.  ;o(  I truely believe at the core GNOME
is better though, but I like things like this to just work...  I'm hoping
our current stuff fixes it tho.

Note You need to log in before you can comment on or make changes to this bug.