This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 154408 - Installer and s-c-display does not add proper configuration information into the xorg.conf file.
Installer and s-c-display does not add proper configuration information into ...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Matrox G100 crahes on install and pos...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-11 11:32 EDT by Jim Cornette
Modified: 2014-06-18 05:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:45:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
During install attempt temp-ramfs-x.log (32.04 KB, text/plain)
2005-04-11 11:34 EDT, Jim Cornette
no flags Details
temp-x.log.log (1.28 KB, text/plain)
2005-04-11 11:35 EDT, Jim Cornette
no flags Details
temp-XConfig.test (3.50 KB, text/plain)
2005-04-11 11:36 EDT, Jim Cornette
no flags Details
What Debian install did using same hardware/ computer (2.90 KB, text/plain)
2005-04-11 11:38 EDT, Jim Cornette
no flags Details
xorg.conf (2.96 KB, text/plain)
2005-04-11 11:39 EDT, Jim Cornette
no flags Details
Matrox G200 on FC4 (40.92 KB, text/plain)
2005-10-17 21:00 EDT, Jim Cornette
no flags Details
Xorg.conf for Matrox (3.47 KB, text/plain)
2005-10-17 21:02 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2005-04-11 11:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050327

Description of problem:
Per postings to the fedora-list, it was asked if anyone could give advice regarding configuring a Matrox G100 card during install and post install. The problem was present until the below was done to get Fedora Core 3 installed on this machine.

Excerpt;
So, I changed my video card and I installed FC3 without problems. I
used ATI Rage video card.
After this, a put my Matrox G100 back and I installed Debian.
My HD has 2 Linux: FC3 and Debian.

Debian uses XF86 and It found my video card Matrox G100 without problems.

So, I entered at Debian, and I copied the text at /etc/X11/XF86Config-4 to
Fedora /etc/X11/xorg.conf
I am sending these files.

After this, Fedora works ok

So, the problema is: FC3 can´t find Matrox G100 alone.
I have to change de file /etc/X11/xorg.conf

Thank you very much.

Paulo

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Tried to give advice to use text install
2. Advice did not help
3. user found a solution, though more work than should be required to install FC3
4. Advised to file report to make future installations a bit less painful.
5. Submitted report to help resolve this matrox G110 problem for FC4 and future releases. Also to allow current FC3 users to get some help to correct problem.
  

Actual Results:  1. no problem, email went out
2. did not know resolution
3. Happy to see another user of FC3 and steps to get it installed.
4. Bugzilla is a little too complicated for users where English is not their native language. Wanting to see an improvement in future versions installability, passing on info to resolve Marox issue.

Expected Results:  1 and 2. no advice needed. The installation went flawlessly. 
4 and 5. - Bugzilla needs to be simplified and easy for sight impaired and other than English usage improved. (Another bug issue RFE)

Additional info:

There are several configuration files generated during install and after installation that will be added to the report. These were from the user that found the solution to overcome the config error for x11.
Comment 1 Jim Cornette 2005-04-11 11:34:41 EDT
Created attachment 112950 [details]
During install attempt  temp-ramfs-x.log

This file was during install attempt
Comment 2 Jim Cornette 2005-04-11 11:35:27 EDT
Created attachment 112951 [details]
temp-x.log.log

During install attempt
Comment 3 Jim Cornette 2005-04-11 11:36:13 EDT
Created attachment 112952 [details]
temp-XConfig.test

during install attempt
Comment 4 Jim Cornette 2005-04-11 11:38:02 EDT
Created attachment 112953 [details]
What Debian install did using same hardware/ computer

This configuration file worked. This was used to get Fedora working also.
Comment 5 Jim Cornette 2005-04-11 11:39:13 EDT
Created attachment 112954 [details]
xorg.conf

I think this is the bombed xorg.conf file for this card. Submitting on behalf
of another user, I am not sure.
Comment 6 Jim Cornette 2005-10-17 21:00:35 EDT
Created attachment 120105 [details]
Matrox G200 on FC4

I am trying to setup a Matrox Millinium G200 and cannot get the secondary
display to show anything. The primary display has to be configured manually.
Comment 7 Jim Cornette 2005-10-17 21:02:27 EDT
Created attachment 120106 [details]
Xorg.conf for Matrox

Some editing was done to allow 1280x1024 resolution.
Comment 8 Jim Cornette 2005-10-17 21:11:55 EDT
refer to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144597
for troubles with the dual displays on rawhide. (Last six attachments)

I at least get a display withy rawhide. However, when booting, the main display
(Intel 815) goes through POST, Grub loader and partially displays when booting
the kernel. Then the secondary display shows thebooting messagesand login
screen. Once X starts, you get a screen displayed on the Intel 815 (primary),
but only a terminal on VT 1-6 switching.When using the dual head display mode.
1280x1024 is on the main display (Intel) but only blotchy segments with video
information (colors of desktop seen for background image (all mangled) The
screen menu shows640x480 resolutions on any display attached to it.
Comment 9 Jim Cornette 2005-11-28 15:45:50 EST
I cannot decode this bug report myself and seemed to submit part based on
another person's problem.
The MGA card that I tried to configure dual-boot now displays portions of the
text boot and when configured as dual display only shows garbage which is
unreadable (not viewable just changing garbage which changes when mouse hovered
over screen area.) 
Marking bug as deferred since I cannot distinguish what the actual problem was
from reviewing report.

Note You need to log in before you can comment on or make changes to this bug.