This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 154427 - spec file for mysql-4.1.11-2 wants to patch a re-named file
spec file for mysql-4.1.11-2 wants to patch a re-named file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-11 12:36 EDT by Joe Christy
Modified: 2013-07-02 23:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 16:41:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log of failing build (925 bytes, text/plain)
2005-04-11 12:36 EDT, Joe Christy
no flags Details

  None (edit)
Description Joe Christy 2005-04-11 12:36:04 EDT
Description of problem:
Patch2: mysql-errno.patch in the spec for mysql-4.1.11-2 applies to
include/global.h, yet there is no include/global.h. 

Version-Release number of selected component (if applicable):
4.1.11-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -i mysql-4.1.11-2.src.rpm
2. rpmbuild -ba mysql.spec
3.
  
Actual results:
build fails in %prep

Expected results:
build succeeds

Additional info:
The  file to be patched appears to have been re-named my_globals.h. The position
of the patch is now around 50 lines lower in the file, so a new patch will need
to be generated.
Comment 1 Joe Christy 2005-04-11 12:36:04 EDT
Created attachment 112955 [details]
log of failing build
Comment 2 Tom Lane 2005-04-11 12:57:18 EDT
Huh?  mysql-errno.patch has said my_global.h since mysql-4.1.7.

$ head mysql-errno.patch
diff -Naur mysql-4.1.7-orig/include/my_global.h mysql-4.1.7/include/my_global.h
--- mysql-4.1.7-orig/include/my_global.h        2004-10-23 03:28:43.000000000 -0
400
+++ mysql-4.1.7/include/my_global.h     2004-10-27 21:13:26.335448200 -0400
@@ -102,6 +102,10 @@
 #define _GNU_SOURCE 1
...

I think you got confused between this and the 3.x version of the same patch
file.
Comment 3 Joe Christy 2005-04-11 16:26:30 EDT
I see what happened - seeing that both had new versions in Rawhide, I rpm -i'ed
both mysql-4.1.11-2.src.rpm and mysqlclient10-3.23.58-6.src.rpm and the patch
from mysqlclient has the same name as the patch from mysql and overwrote it.

Clearing out my rpm build tree, then building them sequentially resolved the
problem. 

Doh!

This bug should be closed.
Comment 4 Tom Lane 2005-04-11 16:41:24 EDT
Yeah, the setup doesn't support building those two in parallel.  It's a bit of a
gotcha, but using versioned names for the files is more of a pain than it seems
worth to avoid the gotcha.  Sorry for your trouble.

Note You need to log in before you can comment on or make changes to this bug.