Bug 154467 - kernel update was compiled with different gcc version
kernel update was compiled with different gcc version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-11 20:21 EDT by Florin Andrei
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.4.3-22.fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 17:35:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2005-04-11 20:21:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
This kernel update appears to have been built with gcc-3.4.3, while the compiler currently available on FC3 is gcc-3.4.2
This causes problems with some applications that require additional kernel modules.
Please either release a gcc update, or a new kernel update that was compiled with the current gcc.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
  

Additional info:
Comment 1 Warren Togami 2005-04-11 20:28:58 EDT
Have you *tried* kernel modules built with gcc-3.4.3 anyway?  They seem to work
for me in FC3 with these kernels.  Anyway, reassigning to gcc.  We'll let jakub
decide.
Comment 2 Florin Andrei 2005-04-11 20:51:12 EDT
I tried, it fails. There could be many reasons for the failure, true, and i
didn't look too closely (not that i'm a kernel modules expert anyway), but...
well, that's it.
Comment 3 Dave Jones 2005-04-11 20:55:46 EDT
gcc-3.4.3 is in updates-testing.
Comment 4 Matthew Miller 2005-04-11 23:22:16 EDT
FWIW, openafs seems to work fine (for the current definition of openafs working
fine) with the new kernel and gcc 3.4.2.
Comment 5 Warren Togami 2005-04-12 00:06:05 EDT
> for the current definition of openafs working fine

LOL!

Note You need to log in before you can comment on or make changes to this bug.