Bug 154488 - /proc/partitions show bogus device files for disks that are not present
/proc/partitions show bogus device files for disks that are not present
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 02:41 EDT by Karthik G.S.B.
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 04:26:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karthik G.S.B. 2005-04-12 02:41:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When the user creates a fiber channel disk is removed from the linux host when the system is powered down, on reboot the linux system adds bogus device entries in /proc/partitions and tries I/O on the device.

The system under description had a qlogic driver installed (qla2300)

Example:
 /dev/sda and /dev/sdb are valid disks; here RHAS has added /dev/sd

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. Expose two disks to the linux host over fiber-channel
2. On boot, verify that both the disks are visible /dev/sda and /dev/sdb
3. Shutdown the linux system
4. Remove the second disk
5. Boot the system
6. cat /proc/partitions

  

Actual Results:  Step1 was tried with four disks and Step4 was tried by removing two disks. The output is as follows:

#### /dev/sda and /dev/sdb contain 3 valid partitions
#### /dev/sdc and /dev/sdd are not present at all

# cat /proc/partitions
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse running use aveq

   8     0   41943040 sda 2456 4873 56298 7990 1552 1837 27226 1760 0 7620 9750
   8     1     104391 sda1 22 106 256 90 1 0 2 0 0 90 90
   8     2   41311147 sda2 2367 4568 55450 7740 1551 1837 27224 1760 0 7430 9500
   8     3     522112 sda3 14 44 176 60 0 0 0 0 0 60 60
   8    16   41943040 sdb 114 454 1136 270 0 0 0 0 0 260 270
   8    17     104391 sdb1 19 81 200 80 0 0 0 0 0 80 80
   8    18   41311147 sdb2 18 78 192 70 0 0 0 0 0 70 70
   8    19     522112 sdb3 30 162 384 70 0 0 0 0 0 70 70
   8    32   41943040 sdc 5 15 40 10 0 0 0 0 0 10 10
   8    48   41943040 sdd 5 15 40 0 0 0 0 0 0 0 0


### I/O activity on the device /dev/sdc and /dev/sdd

# tail -10f /var/log/messages
Apr 12 10:32:57 linux kernel: Device 08:20 not ready.
Apr 12 10:32:57 linux kernel:  I/O error: dev 08:20, sector 0
Apr 12 10:32:57 linux kernel: Device 08:30 not ready.
Apr 12 10:32:57 linux kernel:  I/O error: dev 08:30, sector 0
Apr 12 10:34:19 linux kernel: Device 08:20 not ready.
Apr 12 10:34:19 linux kernel:  I/O error: dev 08:20, sector 0
Apr 12 10:34:19 linux kernel: Device 08:30 not ready.
Apr 12 10:34:19 linux kernel:  I/O error: dev 08:30, sector 0

# uptime
 10:36:50  up 9 min,  1 user,  load average: 0.00, 0.02, 0.00



### Error report from fdisk -l
### this error is always reported

# fdisk -l

Disk /dev/sda: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        13    104391   83  Linux
/dev/sda2            14      5156  41311147+  83  Linux
/dev/sda3          5157      5221    522112+  82  Linux swap

Disk /dev/sdb: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1   *         1        13    104391   83  Linux
/dev/sdb2            14      5156  41311147+  83  Linux
/dev/sdb3          5157      5221    522112+  82  Linux swap
 I/O error: dev 08:20, sector 0     <------------   [ for /dev/sdc ]
 I/O error: dev 08:30, sector 0     <------------   [ for /dev/sdd ]



Expected Results:  1. fdisk -l or cat /proc/partitions need not list the entries
2. No error I/O on those false devices


Additional info:

# cat /etc/issue
Red Hat Enterprise Linux AS release 3 (Taroon Update 3)
Comment 1 Karthik G.S.B. 2005-04-12 04:26:46 EDT
I would like to recall this problem as this was due to multiple paths from the
host to the same disk. This was detected from kudzu hwinfo.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.