Bug 15451 - Giving nousb as kernel option does not work
Summary: Giving nousb as kernel option does not work
Status: CLOSED DUPLICATE of bug 15464
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-04 22:21 UTC by Peter Kjellerstedt
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 22:21:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Kjellerstedt 2000-08-04 22:21:12 UTC
When I tried to give nousb as a kernel option I got an error from
rc.sysinit. It turned out that there was an error in the if statement
testing for the nousb option to be present in /proc/cmdline. The following
patch should fix it:

--- /etc/rc.d/rc.sysinit.org    Fri Aug  4 23:39:44 2000
+++ /etc/rc.d/rc.sysinit        Tue Aug  1 03:11:04 2000
@@ -146,7 +146,7 @@
 
 # Initialize USB controller and HID devices
 
-if [  grep -q "nousb" /proc/cmdline 2>/dev/null ]; then
+if grep -qi "nousb" /proc/cmdline 2>/dev/null ; then
     usb=0
 else
     usb=1

(BTW, the reason I needed to use nousb was that I got an OOPS when the USB
module was insmod'ed, so I figured I would just turn it of since I do not
use USB anyway. Contact me if you want information about that OOPS and I
will see if I can get it to happen again.)

Comment 1 Jeremy Katz 2000-08-05 19:59:29 UTC
15464 also mentions a couple other places where this is the case

*** This bug has been marked as a duplicate of 15464 ***


Note You need to log in before you can comment on or make changes to this bug.