Bug 154538 - r200_dri with maya
r200_dri with maya
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 11:11 EDT by iremets
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 18:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description iremets 2005-04-12 11:11:33 EDT
Description of problem:
Just tried a valid maya 6.5 license on FC4-devel for testing purpose. 
Computer: laptop with ATI R250 (firegl 9000) - xorg radeon/r200_dri drivers and
          dri enabled -> Maya hangs on startup.
dri disabled -> Maya GL is slow but runs fine
Why I post here:
Maya also runs fine on the last ubuntu distro with xorg 6.8.2 and r200_dri
drivers - dri enabled

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-20

How reproducible:
every time beeing a normal user as well as beeing root

Steps to Reproduce:
1. Lauch Maya 6.5
  
Actual results:
As soon as the GL interface part is drawn, maya hangs. Tracing with gdb, it
seems to be messed up in the r200_dri. 

Expected results:
Working r200_dri GL

Additional info:
works at least on ubuntu hoary with same xorg version - dri enabled.
Comment 1 Mike A. Harris 2005-04-15 06:18:14 EDT
Please report this issue to X.Org developers, in the X.Org bug tracker
located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.
Comment 2 Mike A. Harris 2005-04-15 06:27:17 EDT
Setting status to "NEEDINFO", awaiting X.Org bug report URL for tracking
purposes.
Comment 3 Mike A. Harris 2005-05-16 18:52:47 EDT
You mention it doesn't occur in Ubuntu, which means that it is either
a bug in stock X.org and Ubuntu has a patch that fixes it, or it is
a bug in stock X.Org that for some other reason does not trigger
under Ubuntu (perhaps kernel related), or it could be something else.

We do not have Maya available to be able to investigate this problem
directly, and there have not been any responses in this bug report
for over a month now.

If the problem still exists in the latest updates for Fedora Core,
file a bug report in X.Org bugzilla as requested above and Red Hat
will continue to track the issue in the X.org bugzilla.

If someone can provide a reproduceable test case that doesn't require
having a legally licensed copy of Maya, or can provide enough
debugging information in the X.Org bug report once it is filed,
which can help developers to diagnose the cause of the problem,
then someone can probably fix the issue in X.Org directly (perhaps
Ubuntu can submit their patch if they have one), and all distributions
can obtain the centralized fix for the issue.

Setting status to "ERRATA", assuming bug is fixed in current updates
due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.