Bug 154556 - ip.sh doesn't correctly check link states of bonded ethernet devices
ip.sh doesn't correctly check link states of bonded ethernet devices
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 13:25 EDT by Lon Hohberger
Modified: 2009-04-16 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-12 11:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing behavior. (2.83 KB, patch)
2005-04-12 14:12 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2005-04-12 13:25:47 EDT
Description of problem:

Checking the link states of bonded ethernet devices requires running through
each physical (slave) interface and seeing if their link state is up or not. 
This was fixed in clumanager (as of 1.2.26.1), and is a regression.
Comment 1 Lon Hohberger 2005-04-12 13:26:58 EDT
Impact: Checking the link states of a bonded ethernet device where we bind a
service IP address will always fail, causing restarts and/or failover.
Comment 4 Lon Hohberger 2005-04-12 14:12:15 EDT
Created attachment 113044 [details]
Patch fixing behavior.
Comment 5 Lon Hohberger 2005-04-19 17:20:58 EDT
Fix in... cvs ... all ... branches

Note You need to log in before you can comment on or make changes to this bug.