Bug 154561 - mdadm can't handle >2TB array members
mdadm can't handle >2TB array members
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mdadm (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 13:57 EDT by Joshua Baker-LePain
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0290
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Baker-LePain 2005-04-12 13:57:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
My system has 2 3ware 9500-12 boards in it, each presenting the OS with a ~3TB disk.  I tried to assembe these into a RAID0 stripe, and:

[jlb@$HOST ~]$ sudo mdadm -C /dev/md0 -c 4096 -l 0 -n 2 /dev/sda4 /dev/sdb4
mdadm: Cannot get size of /dev/sda4: File too large
mdadm: Cannot get size of /dev/sdb4: File too large
mdadm: create aborted


Version-Release number of selected component (if applicable):
mdadm-1.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. sudo mdadm -C /dev/md0 -c 4096 -l 0 -n 2 /dev/sda4 /dev/sdb4
2. 
3.
  

Actual Results:  It failed.

Expected Results:  It should create and start the array.

Additional info:

I installed mdadm-1.11.0 from http://www.cse.unsw.edu.au/~neilb/source/mdadm/ and it worked just fine.
Comment 1 Doug Ledford 2007-01-31 13:56:52 EST
We are upgrading mdadm from 1.6.0 to 1.12.0 in RHEL4.5, so this problem should
be solved by default.  I can't personally test it though due to lack of any
devices > 2TB in size.  However, I'll mark this bug as MODIFIED by the update so
QE can verify your results that it should work (and from code inspection is
should work as well, the new code in 1.12.0 uses an unsigned long long to hold
the device size and only falls back to unsigned long if FBLKGETSIZE64 isn't
available, so as long as the 64bit size syscall is available, mdadm should
support >2TB partitions).
Comment 2 Jay Turner 2007-01-31 17:01:58 EST
QE ack for RHEL4.5.  Will need some testing directives on the mdadm rebase.
Comment 7 Red Hat Bugzilla 2007-05-01 13:46:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0290.html

Note You need to log in before you can comment on or make changes to this bug.