Bug 154586 - Installer does not create the proper grub entries for a succesful reboot after installation, xfs, reiserfs, and md0 raid1 /boot partition are all problems.
Installer does not create the proper grub entries for a succesful reboot afte...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
FC4
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 16:20 EDT by Michael D. Joy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-18 11:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael D. Joy 2005-04-12 16:20:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Hardware:

AMD64 3000+
1024MB of Ram
SIS Chipset, sis_sata driver for disks
2* Hitachi SATA disks. (SDB, SDC)
SII3114 Controller 
1* Maxtor 300GB SATA 16MB Cache (SDA) (/scratch)
Pioneer DVR-108 DVD Rom

When installing the x86_64 version of FC4 Test 1 and 2, formatting the root partition / (with just a root and swap partition) results in an unbootable system. Grub complains of an unknown executable for the vmlinuz kernel. Attempts to install on a system with md0 as /boot raid1 and / as md1 raid0, results in complaints about unknown boot partition.

Note that these partitions are created on SDB and SDC, but this shouldn't be a problem.

I believe the raid problem is attributed to the same old FC3 installer bug that was NEVER fixed, where if md0 was /boot, grub would never boot without some manual tweaking with a knoppix/rescue cd after install.

RHE4 has this same issue because RH ignored the problem.

However, the file system issues are critical. You cannot install with xfs or reiserfs on FC4 T1 or T2 and get a bootable system.

FC4 T1 bombed out trying to format a raid system with xfs or reiser mid install.

Formatting with ext3 is the only way to get a bootable system.

I'm not sure about the x86 version as I haven't tested this. But I'm sure if the x86_64 version is broken, it's likely the x86 one is as well, because these don't look like simple compiler problems.



Version-Release number of selected component (if applicable):
FC4Test 1 and 2

How reproducible:
Always

Steps to Reproduce:
1.Install x86_64 FC4T2 with xfs or reiserfs on / with a swap file

  

Actual Results:  Grub won't boot.

Expected Results:  Grub should boot, and be happy like it is with ext3 filesystems.

Additional info:

The raid problem is tertiary and I may open a separate bug request for it. Hopefully it will get fixed this time! Not being able to have /boot on a raid 1 partition is quite annoying.
Comment 1 Peter Jones 2005-04-18 11:24:24 EDT
Neither XFS nor ReiserFS are supported.  We'll happily review and consider any
patches submitted to make them work better, but don't expect us to fix this.

As far as I know, /boot on raid1 currently works.  If you can reproduce a
failure  with an otherwise supported installation, please file that as a
separate bug.

Note You need to log in before you can comment on or make changes to this bug.