Bug 154592 - yum update missing dependency gcc = 3.4.2 needed by libtool
yum update missing dependency gcc = 3.4.2 needed by libtool
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 17:09 EDT by Keith E. Fleming
Modified: 2014-01-21 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 06:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith E. Fleming 2005-04-12 17:09:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624 Netscape/7.1

Description of problem:
Ran my daily yum update

gcc-3.4.3-22.fc3.i386.rpm is set to be updated, but the presently installed libtool requires 3.4.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum clean all
2. yum update
3.
  

Actual Results:  --> Running transaction check
--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.2 is needed by package libtool


Expected Results:  Complete!

Additional info:
Comment 1 Seth Vidal 2005-04-12 17:35:21 EDT
This isn't a yum bug - this is a repository problem for the updates tree for fc3.

reassigning to libtool
Comment 2 Wayne Doust 2005-04-12 18:36:45 EDT
Experienced this too:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libgcc.i386 0:3.4.3-22.fc3 set to be updated
---> Package gcc.i386 0:3.4.3-22.fc3 set to be updated
---> Package libgnat.i386 0:3.4.3-22.fc3 set to be updated
---> Package gcc-c++.i386 0:3.4.3-22.fc3 set to be updated
---> Package libstdc++.i386 0:3.4.3-22.fc3 set to be updated
---> Package libgcj.i386 0:3.4.3-22.fc3 set to be updated
---> Package gcc-gnat.i386 0:3.4.3-22.fc3 set to be updated
---> Package cpp.i386 0:3.4.3-22.fc3 set to be updated
---> Package libstdc++-devel.i386 0:3.4.3-22.fc3 set to be updated
---> Package gcc-java.i386 0:3.4.3-22.fc3 set to be updated
---> Package autofs.i386 1:4.1.3-114 set to be updated
---> Package libgcj-devel.i386 0:3.4.3-22.fc3 set to be updated
---> Package gcc-g77.i386 0:3.4.3-22.fc3 set to be updated
---> Package libf2c.i386 0:3.4.3-22.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc = 3.4.2 for package: libtool
--> Finished Dependency Resolution
Error: Missing Dependency: gcc = 3.4.2 is needed by package libtool
Comment 3 Need Real Name 2005-04-12 18:48:44 EDT
libtool-1.5.6-4.FC3.2.i386.rpm in testing is needed for the new gcc. It hasn´t
been moved to updates. If it´s not going to be that, the new update can´t be
installed. Easy as that. :) 

Regard
P.E. 
Comment 4 Keith E. Fleming 2005-04-12 18:51:06 EDT
OK, so is there any way to make yum not try to get gcc-3.4.3? I assume that's
the problem, that the gcc and libtool are married, and I can't get one without
the other?
Comment 5 Need Real Name 2005-04-12 18:56:31 EDT
Yes it is so, but have patience redhat will soon move the libtool package. :)
Comment 6 Glen Turner 2005-04-12 20:10:05 EDT
(In reply to comment #5)
> Yes it is so, but have patience redhat will soon move the libtool package. :)

And in the meantime yum applies no security updates :-(

In that sense this is a yum bug too. If a dependency can't be satisfied then the
packages requiring that dependency should be removed from the transaction and
another attempt made. Then unrelated updates could proceed.

Without such a modification the use of second party repositories runs the risk
of those repos blocking updates from other repos (such as updates-released).
Comment 7 David Mohring 2005-04-12 21:00:04 EDT
These days, GCC without libtool is pretty useless. If libtool is dependent on
the current version of GCC, why not just include it in the GCC source RPM? Then
it will be rebuilt automatically.
Comment 8 Alex Lancaster 2005-04-15 00:00:58 EDT
Seems to be fixed now (at least using apt).  A libtool update was pushed to the
FC3 updates tree which allows the gcc updates to proceed.   Please test on yum
and close if fixed.
Comment 9 Gregory Haase 2005-09-02 13:50:20 EDT
I am getting this exact error, but I'm getting this error while moving from
3.4.3 to 3.4.4. I thought it odd. That I was getting the error saying that I
needed 3.4.2, but then I already have 3.4.3.

Could the libtool update mentioned above need to be re-applied to allow the next
set of gcc changes, or is something else on my system awry?
Comment 10 Gregory Haase 2005-09-28 21:27:33 EDT
I'd like to have this bug reopened... simply because I'm still getting it and
there's been no response for more than 3 weeks. It's terribly frustrating in the
least... yum is sitting on 100s of upgrades at this point but is failing out
because of this error.
Comment 11 Seth Vidal 2005-09-28 21:38:09 EDT
it seems like it is just a repository error - can you make sure you're using
updated repositories?
Comment 12 Gregory Haase 2005-09-29 20:42:05 EDT
I looked, and I used to have dag, kde, and freshrpms loaded in, but right now
they are all commented out. I tried both ways.

With all those commented out, the top of the yum output looks like:
Setting up Update Process
Setting up Repos
base                      100% |=========================| 1.1 kB    00:00
updates-released          100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2622/2622
updates-re: ################################################## 1002/1002
Comment 13 Seth Vidal 2005-09-29 23:40:58 EDT
that doesn't tell me if the repositories you're using are current. which mirrors
are you using? Can you paste the section for [base] and [updates-released] from
your yum.conf or yum.repos.d/*.repo files?

thanks
Comment 14 Gregory Haase 2005-10-11 15:10:55 EDT
Sorry about the delay in getting back to this issue. Since there were so many
packages that needed updating, and there wasn't anything critical on the laptop,
I decided just to back up /home and put a fresh install on there.

Note You need to log in before you can comment on or make changes to this bug.