Bug 154619 - kernel does not invoke libata on promise sata378
kernel does not invoke libata on promise sata378
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 22:55 EDT by Robert Thomas
Modified: 2015-01-04 17:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 10:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Thomas 2005-04-12 22:55:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
FC4T2 cannot load and operate a Promise SATA378 TX2 controller either in RAID or ATA mode.  If this helps, Gentoo 2005.0 works ;) .  I've seen this same issue complained about on numerous Internet forums regarding FC2 and FC3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Find system with Promise SATA378 Controller
2.Boot FC4T2 Install CD/DVD
3.Navigate until the diskdruid menu
  

Actual Results:  No drives found to install, installer reboots the system.

Expected Results:  Partition and format drives for install process.

Additional info:
Comment 1 Joe 2005-04-15 17:11:42 EDT
If it helps...I am running yoper-2.2-6 but with the 2.6.11.6 kernel downloaded
from ftp.kernel.org with the following libata patch (by jgarzik) applied which
allows for the Promise SATA378 TX2plus to work (at least in ATA mode, I haven't
tried in RAID mode): 
ftp://ftp.kernel.org/pub/linux/kernel/people/jgarzik/libata/2.6.11-libata-dev1.patch.bz2

It would be great if this could be applied to the anaconda kernel used during
the installation so that systems using this RAID controller can use FC4T2 & above.
Comment 2 Dave Jones 2005-06-27 19:17:30 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 3 Dave Jones 2005-09-30 02:55:15 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 4 Dave Jones 2005-11-10 15:02:08 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 5 Dave Jones 2006-02-03 00:55:19 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 6 Robert Thomas 2006-02-03 01:10:23 EST
I can never tell which kernel flavor of the month is gonna work from 
kernel.org or RH.  So far, I've had success in using the patches 
from here: 
 
http://www.kernel.org/pub/linux/kernel/people/jgarzik/libata/ 
 
What is unique about this system is that when using non-raid, the controller 
is put into PATA mode by the BIOS and this cannot be changed in BIOS setup.  
Then the kernel loads the correct sata_promise driver, but cannot find any 
ports.  The above patch has solved this issue for the past few kernel releases 
for me. 
Comment 7 Aaron Sherman 2006-02-16 08:08:32 EST
I require that patch as well for the MSI k8n Diamond Plus motherboard. The
primary NVIDIA controler works fine on the nForce 4 primary SATA controler, but
for the extra two SATA ports on the motherboard, the SLI controler requires
sata_sil24, only available with the libsata patch. This integration really needs
to be done to better support the modern crop of (especially AMD-base)
motherboards coming out.
Comment 8 Dave Jones 2006-09-16 22:52:57 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 9 Robert Thomas 2006-09-17 03:31:11 EDT
How funny.  I just got this email while installing FC5.  I'm running in RAID
mode now.  Before I was running with just one drive in ATA mode.  RAID mode is
working well, better than upstream kernel even!  I assume since RAID mode is
working that libata would operate the ATA port.
Comment 10 Dave Jones 2006-09-17 10:20:33 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.