Bug 154624 - RHEL4 boot over iscsi HBA fails
RHEL4 boot over iscsi HBA fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-13 00:35 EDT by Bala
Modified: 2008-04-07 01:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-25 20:31:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bala 2005-04-13 00:35:45 EDT
Description of problem:

If RHEL4 is installed over iSCSI on a remote iSCSI taregt using Adaptec ASA72xx 
card the system doesn’t boot up, eventhough the installation goes through. We 
do the installation with "linux dd" command and input the ASA72xx driver.  

We found that the problem could be with Redhat Nash – a boot time shell which 
loads ASA72xx driver. 

It appears that Nash is not waiting till the ASA72xx driver reports all the 
LUN’s and goes ahead and try to mount the root on a non existing device. 

We had a local installation of a RHEL4 on a IDE driver. Using the local 
installation we booted the system and mounted the iscsi disk and modified the
init script on the iscsi installation. We added a few seconds of delay after 
the #insmod asa72xx command and regenerated the initrd. With the new initrd the 
system is able to boot over iscsi.
 


Version-Release number of selected component (if applicable):
RHEL4 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bala 2005-04-13 00:55:07 EDT
-----------modified init file to boot over asa72xx hba----------------------
-----------search for asa72xx below----------------------------------------- 
#!/bin/nash
mount -t proc /proc /proc
setquiet
echo Mounted /proc filesystem
echo Mounting sysfs
mount -t sysfs none /sys
echo Creating /dev
mount -o mode=0755 -t tmpfs none /dev
mknod /dev/console c 5 1
mknod /dev/null c 1 3
mknod /dev/zero c 1 5
mkdir /dev/pts
mkdir /dev/shm
echo Starting udev
/sbin/udevstart
echo -n "/sbin/hotplug" > /proc/sys/kernel/hotplug
echo "Loading scsi_mod.ko module"
insmod /lib/scsi_mod.ko 
echo "Loading sd_mod.ko module"
insmod /lib/sd_mod.ko 
echo "Loading asa72xx.ko module"
insmod /lib/asa72xx.ko 
echo "Loading libata.ko module"
insmod /lib/libata.ko 
echo "Loading ata_piix.ko module"
insmod /lib/ata_piix.ko 
echo "Loading jbd.ko module"
insmod /lib/jbd.ko 
echo "Loading ext3.ko module"
insmod /lib/ext3.ko 

#showlabels
#Following sleep fix is required to boot using asa72xx hba
sleep 2

/sbin/udevstart
echo Creating root device
mkrootdev /dev/root
umount /sys
echo Mounting root filesystem
mount -o defaults --ro -t ext3 /dev/root /sysroot
mount -t tmpfs --bind /dev /sysroot/dev
echo Switching to new root
switchroot /sysroot
umount /initrd/dev
-----------modified init file to boot over asa72xx hba----------------------

Comment 2 Tom Coughlan 2005-09-25 20:31:40 EDT
Red Hat does not ship or support the asa72xx driver. This is primarialy because
it has not been submitted upstream. 

From the problem description, it appears as though the "insmod asa72xx" returns
before all the LUNs have been configured. If we ever add support for this module
we will need to fix that, or make the necessary changes to the system init
script to accommodate this behavior. We are not planning to make a change to fix
this until then.



Note You need to log in before you can comment on or make changes to this bug.