Bug 15464 - rc.sysinit does not allow to disable USB
Summary: rc.sysinit does not allow to disable USB
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 15451 15518 15774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 07:21 UTC by mal
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-05 21:19:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mal 2000-08-05 07:21:34 UTC
there is a bug in 
rc.sysinit which does not allow to disable USB
(which is SEVERELY BROKEN, see
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=15462
)
The problem is with 
if [  grep -q "nousb" /proc/cmdline 2>/dev/null ]; then
this is whong. this line is always false, so USB 
will be always loaded. 
The right line should be 
if   grep -q "nousb" /proc/cmdline 2>/dev/null  
	then
.....
There several other places in initscripts 
with similar bug.

Comment 1 mal 2000-08-05 17:08:51 UTC
There are several other places in rc.sysinit (and probably in some other files
where this problem exists)
another example from rc.sysinit:
if [ -f /fastboot -o grep -q "fastboot" /proc/cmdline 2>/dev/null ]; then

This is incorrect. It probably should be
if [ -f /fastboot  ] || grep -q "fastboot" /proc/cmdline 2>/dev/null ; then

same problem as with USB above.
Also check the other files on this type of error.


Comment 2 Jeremy Katz 2000-08-05 19:59:27 UTC
*** Bug 15451 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2000-08-05 21:19:27 UTC
*** Bug 15518 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2000-08-06 17:11:51 UTC
This will be fixed in initscripts-5.40-1.

Comment 5 Bill Nottingham 2000-08-08 21:49:53 UTC
*** Bug 15774 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.