Bug 154644 - 'strace64 date' segfaults
'strace64 date' segfaults
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: strace (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-04-13 06:12 EDT by Jay Turner
Modified: 2015-01-07 19:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-12 05:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
'strace64 strace64 date' output (59.77 KB, text/plain)
2005-04-13 06:12 EDT, Jay Turner
no flags Details

  None (edit)
Description Jay Turner 2005-04-13 06:12:13 EDT
Description of problem:
With both 4.5.8-1 and 4.5.9-2.EL4 I'm seeing 'strace64 date' segfault.  'strace
date' completes successfully.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jay Turner 2005-04-13 06:12:13 EDT
Created attachment 113086 [details]
'strace64 strace64 date' output
Comment 2 Roland McGrath 2005-04-21 16:54:26 EDT
Has this ever worked?  date is a 32-bit binary, right?
Comment 3 Jay Turner 2005-04-25 04:03:53 EDT
Yes, 'date' is a 32-bit binary:

# file `which date`
/bin/date: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV),
for GNU/Linux 2.2.5, dynamically linked (uses shared libs), stripped

I labelled it 'not a regression' during testing, so I'm not sure that it's ever
worked, but maybe something to look into.
Comment 4 Dmitry V. Levin 2006-01-06 18:01:17 EST
It looks like another illustration for the problem I described in RH#173050.
Comment 5 Roland McGrath 2006-01-12 05:21:08 EST
ppc32 strace does not handle ppc64 binaries and ppc64 strace does not handle
ppc32 binaries.  That's why there is an strace64 rpm on ppc64, so you can use
strace64 for 64-bit binaries and strace for 32-bit binaries.

Note You need to log in before you can comment on or make changes to this bug.