Bug 154673 - Installer hangs during AGPGART test
Installer hangs during AGPGART test
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 154569 154695 154723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-13 09:55 EDT by Dan Kane
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 01:04:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kane 2005-04-13 09:55:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
Been having issues with installing Fedora since FC3 (see bug #122760 for history and machine specs - attachments)

When installing FC4t1 on my Dell Dimension 4500 S (no jokes please ;-), the installer hangs after testing AGPGART..."linux noprobe" and "linux skipddc" (and combined) have no effect.

The last line of output before it hangs is a report about finding some "stolen memory", presumably reserved by the onboard (but unused) AGP graphics chipset.

The saga continues ;-)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Power up with CD #1 in drive
2. At prompt, enter "linux resolution=1280x1024"
3. Elvis leaves with the fat lady
  

Actual Results:  Tears...questioning the fabric of reality and the injustice of it all...

Expected Results:  Happiness, enlightenment and unbounded joy

Additional info:
Comment 1 Dave Jones 2005-04-13 15:00:38 EDT
can you boot with agp=off ?

Can you send the output of lspci please ?
Comment 2 Dave Jones 2005-04-13 15:33:38 EDT
*** Bug 154695 has been marked as a duplicate of this bug. ***
Comment 3 Dan Kane 2005-04-13 15:54:21 EDT
*** Bug 154723 has been marked as a duplicate of this bug. ***
Comment 4 Dan Kane 2005-04-13 15:57:00 EDT
Apologies for duplicates...a browser bookmarking snafu :-)
Comment 5 Dan Kane 2005-04-18 13:27:20 EDT
Resuming my attempts to install FC4 with test 2 now...

Thanks, Dave, for the "agp=off" suggestion. This did indeed allow the
installation of FC4t2 to proceed to completion (only observable flaw were some
invisible buttons that needed the mouse pointer to be moved over them to cause
them to display).

Sadly, upon reboot, we were back in the land of 'Oops'. A summary of the output
is as follows:

>>>

Starting udev:
Initializing hardware... storageUnable to handle kernel paging request at
virtual address 277ca005
  printing eip:
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: 8139too mii floppy ext3 jbd
CPU: 0
EIP: 0060 : [<c012886b>] not tainted VLI
EFLAGS: 0010202 (2.6.11-1.1226_FC4)
EIP is at __request_resource + 0x24/0x49
eax: 277ca001 ebx: fdeffc00 ecx: c0004014 edx: fdeffcff
esi: c03d1b3c edi: e685664c ebp: fdeffc00 esp: e787be40
ds: 007b es: 007b ss: 0068
Process modprobe (pid: 991, threadinfo = e787b000 task = e7a0a550)
Stack: ...
       ...
Call Trace: ...
            ...
Code: ...
      ...
/etc/rc.d/rc.sysinit: line 165: 991 Segmentation fault modprobe $1>/dev/null 2>&1
<b>8139cp: 10/100 PCI Ethernet driver v1.2 (Mar22, 2004)

>>>

When I attempted to install FC4t2 *without* the "agp=off" option, the installer
'Oops' occured early in the initialization process, after "running /bin/loader",
except that the culprit listed on the final line of output as "<6>USB Universal
Host Controller Interface driver v2.2". However, CTRL-ALT-DEL was still able to
trigger a reboot ("kseriod exiting...").

I have just realized that I haven't included the requested output from
"lspci"...I will post this this evening.
Comment 6 Dave Jones 2005-04-18 14:21:00 EDT
unfortunatly, you snipped out the important part. We need that call trace
information to know where this happened.

Unless it mentions AGP, can you file that as a seperate bug to avoid cluttering
this one with other problems ?

Thanks.
Comment 7 Dave Jones 2005-05-23 19:50:33 EDT
*** Bug 154569 has been marked as a duplicate of this bug. ***
Comment 8 Dave Jones 2005-06-27 19:14:59 EDT
Mass update for bugs reported against -test:
Updating version field to FC4 final. Please retest with final FC4 release if you
have not already done so. Thanks.
Comment 9 Joe Cooper 2005-09-23 18:35:25 EDT
Just to add to this, I have a batch of oldish (circa 2001) Supermicro dual PIII
servers that exhibit the agpgart freeze problem for FC4, FC devel (downloaded
Sept 23, 2005), and RHEL 4 Update 1.

agp=off allows installation to proceed.
Comment 10 Fedora Update System 2005-09-29 23:11:37 EDT
From User-Agent: XML-RPC

kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Dave Jones 2005-09-30 01:04:29 EDT
after installing the box with agp=off, and updating to this errata kernel, agp
operation should be fixed.
Comment 12 Basem Narmok 2005-11-08 17:49:01 EST
I have the same problem with FC4 latest kernel 2.6.13!!

Note You need to log in before you can comment on or make changes to this bug.