Bug 154726 - pump does not set MTU when setting up a device
pump does not set MTU when setting up a device
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: pump (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-13 16:07 EDT by Sean Dilda
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 14:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to cause pump to set the mtu (575 bytes, patch)
2005-04-13 16:07 EDT, Sean Dilda
no flags Details | Diff
Updated patch (1.50 KB, patch)
2005-04-14 15:13 EDT, Sean Dilda
no flags Details | Diff

  None (edit)
Description Sean Dilda 2005-04-13 16:07:44 EDT
If the flags are set for pump to change the MTU on a device, it ignores those flags.

The following patch will cause the MTU to be set when pumpSetupInterface is called.

This is required for an MTU= setting in /tmp/netinfo to take effect during an
install.
Comment 1 Sean Dilda 2005-04-13 16:07:45 EDT
Created attachment 113114 [details]
Patch to cause pump to set the mtu
Comment 2 Sean Dilda 2005-04-14 15:13:53 EDT
Created attachment 113179 [details]
Updated patch

This patch also allows pump to grab the MTU from the dhcp server (but only if
the dhcp server is configured to send this information).  It also includes the
previous patch that allows pump to set the MTU.

In theory these combined changes will allow anaconda to get the MTU from the
dhcp server at install time without the admin having to specify it in any other
way.
Comment 3 Jeremy Katz 2005-04-20 12:04:58 EDT
Committed to HEAD for pump 0.8.22.  Should also make its way into RHEL3 U6 and
RHEL4 U2 based on a related feature request.
Comment 4 Jeremy Katz 2006-04-24 14:03:41 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.