Bug 154731 - Evolution's Alarm dialog can lock up X display
Evolution's Alarm dialog can lock up X display
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 154732 154734 154735 154736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-13 17:01 EDT by Dave Malcolm
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 12:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-04-13 17:01:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.1 Fedora/1.0.1-6

Description of problem:
dpeternell demonstrated a problem where the evolution-alarm-notify dialog had popped up whilst the "To:" autocomplete dropdown had appeared.

It had become impossible to click on any UI elements in the X display.  Keyboard events continued to be processed.

Appears to require sysadmin intervention before the user can regain control of the session (switching to a virtual terminal with Ctrl-Alt-F1 then killing the evolution-alarm-notify process does the trick, but an end-user can't be expected to know that)

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Run Evolution, 
2. Set up an LDAP adressbook source; enable autocompletion for that source.
3. set up an alarm due to happen in next minute
4. Start composing an email; start typing in To: and try to get autocomplete to fire as the alarm dfialog pops up.
  

Actual Results:  Display appears to lock up.

Additional info:

evolution-2.0.2-14
Comment 2 Suzanne Hillman 2005-04-14 11:43:21 EDT
*** Bug 154732 has been marked as a duplicate of this bug. ***
Comment 3 Suzanne Hillman 2005-04-14 11:44:58 EDT
*** Bug 154734 has been marked as a duplicate of this bug. ***
Comment 4 Suzanne Hillman 2005-04-14 11:45:12 EDT
*** Bug 154735 has been marked as a duplicate of this bug. ***
Comment 5 Suzanne Hillman 2005-04-14 11:45:27 EDT
*** Bug 154736 has been marked as a duplicate of this bug. ***
Comment 8 Dave Malcolm 2005-06-17 19:15:48 EDT
Looks like I accidentally created 5 identical bugs when opening this bug, and
shillman duped them back to this one (they're identical, and have consecutive IDs)

So are lots of people really hitting this?
Comment 11 RHEL Product and Program Management 2006-07-21 12:28:41 EDT
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.