Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 154777 - FC4T2 (or T1) will not print to a turboprint 1.91-2 defined printer
FC4T2 (or T1) will not print to a turboprint 1.91-2 defined printer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-13 23:11 EDT by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-03 20:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested result of grep /var/log/messages (1.85 KB, text/plain)
2005-04-25 21:57 EDT, Gerry Tool
no flags Details
requested results of grep avc /var/log/audit/audit.log (25.92 KB, text/plain)
2005-04-25 22:00 EDT, Gerry Tool
no flags Details
requested results of grep avc /var/log/audit/audit.log (31.17 KB, text/plain)
2005-04-27 21:24 EDT, Gerry Tool
no flags Details
requested result of grep /var/log/messages (31.73 KB, text/plain)
2005-04-27 21:25 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2005-04-13 23:11:46 EDT
Description of problem:Application turboprint 1.91-2 from turboprint.de does not
work with FC4Tx - it has worked with all former RHL and FC versions.


Version-Release number of selected component (if applicable):
system-config-printer-0.6.128-1

How reproducible:Always


Steps to Reproduce:
1.Install turboprint 1.91-2 from rpm
2.Setup turboprint for a networked LPD print server
3.Try to print a test page or print from an app.
  
Actual results: No printing occurs.  Printer interface believes all is well -
both turboprint setup and localhost:631 interfaces.  Defined printer shows up in
printer dialogs in apps such as gedit.  Printing appears to work, but nothing
ever happens at the printer.


Expected results: Page should print


Additional info: Printing is working for a Samsung ML-1750 laser printer
attached to a second port on the networked LPD print server.  Turboprint defined
printers identical to this setup work in FC3, FC2, ubuntu 5.04, suse9.2 and
several other distros I've tried.

I have reported this bug to turboprint.de also.
Comment 1 Tim Waugh 2005-04-14 05:00:25 EDT
If you find that the cause is a CUPS bug, please re-open.
Comment 2 Gerry Tool 2005-04-22 23:38:27 EDT
It occurred to me that SELinux might be involved.  I disabled SELinux, and the
Canon printer prints via Turbolinux.  I reenabled, and left it set to Permissive
and it still prints.  I set it to Enforce, and it does not print.

So, it appears that SELinux set to Enforce will not allow Turboprint/Canon
printer to print, whereas set to Permissive does.

I do not understand SELinux well enough to know if there is some parameter in
SELinux that I can change to allow Enforce to work along with Turboprint.
Comment 3 Daniel Walsh 2005-04-25 11:00:54 EDT
You should see AVC messages in you log files that will tell us what SELinux is
denying.  Please attach the AVC messages.

Dan
Comment 4 Gerry Tool 2005-04-25 20:01:44 EDT
I would like to do that, but evidently do not know where to look.  If I do a
grep AVC * 
in the /var/log directory, I get nothing.

Also, what condition do you want set in the SELinux tab in Security Level
Configuration when I do this?  Printing succeeds if SELinux is Enabled, but
Enforcing is set to Permissive; it fails if Enforcing is set to Enforcing.

Thanks.
Comment 5 Daniel Walsh 2005-04-25 21:43:13 EDT
grep  avc /var/log/messages  
or
grep avc /var/log/audit/auditd.log
Comment 6 Gerry Tool 2005-04-25 21:57:10 EDT
Created attachment 113658 [details]
requested result of grep /var/log/messages
Comment 7 Gerry Tool 2005-04-25 22:00:03 EDT
Created attachment 113659 [details]
requested results of grep avc /var/log/audit/audit.log

There was no /var/log/audit/auditd.log file, so this attachment is the result
of grep avc /var/log/audit/audit.log
Comment 8 Daniel Walsh 2005-04-26 13:20:16 EDT
Fixed in selinux-policy-*-1.23.13-3
Comment 9 Gerry Tool 2005-04-27 21:22:25 EDT
I now have this installed:

[root@gst-fc4t2 ~]# rpm -q selinux-policy-targeted
selinux-policy-targeted-1.23.13-3

and I still must have SELinux Enforcing Current: Permissive to print.

If I set it to SELinux Enforcing Current : Enforcing,
the print job completes according to Document print status, but nothing prints.

I will again attach the files you previously requested.
Comment 10 Gerry Tool 2005-04-27 21:24:57 EDT
Created attachment 113752 [details]
requested results of grep avc /var/log/audit/audit.log
Comment 11 Gerry Tool 2005-04-27 21:25:44 EDT
Created attachment 113753 [details]
requested result of grep /var/log/messages
Comment 12 Gerry Tool 2005-05-03 20:49:12 EDT
This bug now appears to be fixed with:
[root@gst-fc4t2 ~]# rpm -q selinux-policy-targeted
selinux-policy-targeted-1.23.14-2

I can now print via a turboprint-defined printer with SELinux set to enforcing.

Thanks for the bug fix.

Gerry Tool

Note You need to log in before you can comment on or make changes to this bug.