Bug 154820 - Soundcard detected but no sound from Alsa
Soundcard detected but no sound from Alsa
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 09:37 EDT by Dara Dorsaneo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 05:27:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dara Dorsaneo 2005-04-14 09:37:13 EDT
Description of problem:
Sound card detected but there is no sound output.
I'm running an Audigy 2 card. It is detected and alsa appears to be running fine
but can't pin point the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Never got it working. I'm 99% sure it's not a kernel thing. I've run the default
installed kernel, a build of 2.6.11.6 and 2.6.11.7.
On Fedora Core 4 T1, sound was fine with the same .config for 2.6.11.6 so has to
be one of the packages that changed in Test 2.
Needed Test2 because couldn't get my wireless card working in Test1. Now it
works but I've lost my sound. Please say I don't have to wait until Test3 for a
solution.

Steps to Reproduce:
1. run system-config-soundcard
2. test sound
3. hear nothing
  
Actual results:
Nothing which sucks

Expected results:
To hear a very good music library while surfing the net.

Additional info:
Comment 1 Martin Stransky 2005-04-20 06:17:25 EDT
Which version of alsa-lib do you have?
Comment 2 Martin Stransky 2005-04-20 06:20:58 EDT
Could you try to run " aplay -D plug:hw /usr/share/sounds/email.wav" ?
What happens? Any errors?
Comment 3 Dara Dorsaneo 2005-04-20 09:40:08 EDT
The version of alsa at the time I reported the problem was 1.0.8

I have since tried using 1.0.9-rc2, and this has affected the system a great
deal. I will try to return the system to its original state and perform the test
you asked for.

I should get back today.
Comment 4 Martin Stransky 2005-04-20 09:45:58 EDT
If it works with 1.0.9-rc2, you don't have to test 1.0.8...
Did you change alsa-lib only, or all alsa packages? (alsa-lib, alsa-utils,
alsa-driver).
Comment 5 Dara Dorsaneo 2005-04-20 11:30:01 EDT
I changed libs, utils, and the driver, but not well. dmesg showed that 1.0.8 was
starting each time. I never had to change alsa before so I didn't do it well the
first time.

I have since re-installed the core and can now show the ouput for the aplay
command, "Playing WAVE '/usr/share/sounds/email.wav' : Signed 16 bit Little
Endian, Rate 44100 Hz, Mono".

I heard nothing of course. I first thought it was possibly a mixer device muted
or with no volume, Audigy2 ZS has alot of them.
I can give you any output, log or try anything you think would be useful.
Comment 6 Martin Stransky 2005-04-20 11:41:52 EDT
It really looks like some muted channel in mixer. Could you please attach output
from "amixer" if sound works and if it doesn't works?
Comment 7 Dara Dorsaneo 2005-04-20 12:07:51 EDT
This is the output you requested. The only things a zero I could see were inputs
to the card.

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 74 [74%]
Simple mixer control 'Tone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'Bass',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Limits: 0 - 40
  Mono: 24 [60%]
  Front Left:
  Front Right:
Simple mixer control 'Treble',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Limits: 0 - 40
  Mono: 29 [72%]
  Front Left:
  Front Right:
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control '3D Control Sigmatel - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 3
  Mono: 0 [0%]
Simple mixer control 'PCM',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 75 [75%] Capture 100 [100%]
  Front Right: Playback 75 [75%] Capture 100 [100%]
Simple mixer control 'PCM Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'PCM Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'PCM LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'PCM Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'PCM Surround',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Front',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Surround',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined
  Playback channels: Mono
  Limits: Playback 0 - 100
  Mono: Playback 75 [75%]
Simple mixer control 'Synth',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 28 [90%] [on]
  Front Right: Playback 28 [90%] [on]
Simple mixer control 'Line2',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 31 [100%] [on]
  Front Right: Playback 31 [100%] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 23 [74%] [on]
Simple mixer control 'IEC958 Optical',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'IEC958 Optical Raw',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 11 [73%] [on]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Aux2',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'Analog Mix',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'Audigy Analog/Digital Output Jack',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Audigy CD',0
  Capabilities: pvolume cvolume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 100 Capture 0 - 100
  Front Left: Playback 0 [0%] Capture 0 [0%]
  Front Right: Playback 0 [0%] Capture 0 [0%]
Simple mixer control 'Audigy SPDIF Output Sample Rate',0
  Capabilities:
  Mono:
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Side',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 100
  Front Left: Playback 75 [75%]
  Front Right: Playback 75 [75%]
Simple mixer control 'Sigmatel 4-Speaker Stereo',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Sigmatel Surround Phase Inversion Playback ',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Comment 8 Martin Stransky 2005-04-20 16:23:33 EDT
Is it output from "amixer" if sound works or if it doesn't works?
Comment 9 Dara Dorsaneo 2005-04-20 18:15:35 EDT
It is the output from amixer with the sound not working.

I have since got the 2.6.12-rc2 kernel which has the alsa 1.0.9-rc2 drivers
built in. The result is the same, the card is seen by the system, alsa detects
it and plays sound without any issues, but nothing is heard.

I also did "aplay" with verbose info, and it seems to be fine.

    "aplay -v -D plug:hw /usr/share/sounds/email.wav
     Playing WAVE '/usr/share/sounds/email.wav' : Signed 16 bit Little Endian, 
      
     Rate 44100 Hz, Mono
     Plug PCM: Hardware PCM card 0 'Audigy 2 ZS [SB0350]' device 0 subdevice 1"

I also compiled the alsa driver with debug, but it doens't output as much as I
hoped it would.

    "ALSA sound/pci/emu10k1/emu10k1_main.c:742: vendor=0x1102, device=0x4,    
     subsystem_vendor_id=0x20021102, subsystem_id=0x2002
     ALSA sound/pci/emu10k1/emu10k1_main.c:758: Sound card name=Audigy 2 ZS 
     [SB0350]
     ALSA sound/pci/emu10k1/emufx.c:1385: Installing spdif_bug patch: Audigy 2  
     ZS [SB0350]"
 
What else if anything can effect the sound on a system, and changed between
test1 and test2?
Comment 10 Dara Dorsaneo 2005-04-21 05:34:48 EDT
I have sound. It's nice to hear again.
I've been updating since my re-install and was down to 3 packages to update. The
last package I updated this morning was "udev". I left it as I knew it might
have some effect on the devices. I updated udev on my previous installation but
it started giving errors, and I haven't rebooted since the install of udev-057-1
on this system.

I will boot up with the alsa 1.0.8 and 1.0.9 rc2 drivers in turn and see if the
sound still works. Hopefully it does.
Comment 11 Martin Stransky 2005-04-21 06:09:14 EDT
Great. Thanks for testing.
Comment 12 Dara Dorsaneo 2005-04-21 07:12:43 EDT
Okay checked with both driver versions and it works. So I blame "udev" for the
problem. I don't know why it didn't update properly on the last install but
that's a different problem.

Thanks for the assistance.

Can I leave you change the status to what is best. It's not a problem for ALSA
but this udev version won't be in a release until the next version.

Note You need to log in before you can comment on or make changes to this bug.