Bug 15483 - EMU10k1 and /etc/modules.conf
EMU10k1 and /etc/modules.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-05 11:21 EDT by Brian J. Conway
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:51:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian J. Conway 2000-08-05 11:21:48 EDT
There is something seriously distraught here.  When I use a generic kernel,
but sound card will function, but when I rebuild one 2.4 or 2.2 w/ extra
Live module as I've always done, the module will get loaded and appear to
be playing in XMMS or elsewhere, but no sound will come out.  As I said,
the generic kernel works fine.  I tried changing the line in modules.conf
from alias sound-slot-0 to alias sound, but that didn't do any good.  I'm
sure this is a bug you guys can track down, but what can I do in the
intermediary?
Comment 1 Brian J. Conway 2000-08-06 19:33:45 EDT
I discovered the issue with the previous:  whatever module is included for the
EMU10K1 doesn't have the same mixer settings that the source package or the
source included with test5 have, and was leaving "LINE2" (whatever that actually
may be) empty, which caused the problem.  You might want to include the proper
module and settings along the lines of the following:
[root@ladyluck /]# cat /etc/.aumixrc 
vol:67:67:P
bass:64:64:P
treble:50:50:P
pcm:60:60:P
speaker:50:50:P
line:0:0:P
mic:0:0:R
cd:24:24:P
rec:0:0:P
ogain:50:50:P
line1:75:75:P
line2:75:75:P
line3:50:50:P
dig1:100:100:P
dig2:100:100:P
phin:50:50:P
[root@ladyluck /]#
Comment 2 Bill Nottingham 2000-08-07 00:49:10 EDT
Odd. Was this the emu10k1 module shipped with Pinstripe,
or a different module downloaded out of CVS?
Comment 3 Brian J. Conway 2000-08-07 09:56:20 EDT
This Line1-3 group of settings is included in the daily source snapshots (not
actually CVS) as well as the 2.4-test source, and has always been there.  I am
unsure as why the module included in Pinstripe does not include these, as they
are needed to be turned up when using any other modules besides Pinstripe. 
Check to make sure the source used for the module with 2.2.16 wasn't extremely
old.
Comment 4 Bill Nottingham 2000-08-07 11:40:02 EDT
OK, looks like a kernel problem; assigning there.
Comment 5 Michael K. Johnson 2000-08-18 17:35:18 EDT
Alan, should the 17pre sound we are using fix this?
Comment 6 Alan Cox 2000-08-18 17:50:15 EDT
The 2.2.17pre version is the driver rev Rui recommended I merge. More than that
I cannot answer.

Note You need to log in before you can comment on or make changes to this bug.