Bug 15486 - "edit" icon does not work
Summary: "edit" icon does not work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 17:13 UTC by mal
Modified: 2013-04-02 04:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 16:40:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mal 2000-08-05 17:13:05 UTC
When an icon on desktop is created
doing "right click" , view 
I can see the ~/.gnome-desktop/ICON.desktop content OK.
But when doing "right click" , edit
Emacs is started with no file in it,
emacs is probably started without an argument given.

Comment 1 David Mason 2000-08-05 19:50:10 UTC
changed to mc rather than gnome-core

Comment 2 Pavel Roskin 2000-10-04 01:35:20 UTC
The problem only happens when NEEDS_TERM=false in ~/.gnome/editor
Otherwise the name is passed to the editor.


Comment 3 Pavel Roskin 2000-10-04 16:40:01 UTC
The problem was that emacs was run as "emacs %s" and "%s" was supposed to expand to all tagged files, but this behavior has been broken for some 
time.
I've just checked in a fix in CVS. Here it is if you don't want to wait for 4.5.52:
------------------------------------------
--- src/user.c      Tue Aug 22 18:50:04 2000
+++ src/user.c      Wed Oct  4 12:11:32 2000
@@ -208,8 +208,6 @@
     case 'b': return strip_ext((*quote_func) (fname, 0));
     case 'x': return (*quote_func) (extension(fname), 0);
     case 'd': return (*quote_func) (panel->cwd, 0);
-    case 's': if (!panel->marked)
-               return (*quote_func) (fname, 0);
     case 'i': /* indent equal number cursor position in line */
         if (s_editwidget)
                return g_strnfill (s_editwidget->curs_col, ' ');
@@ -229,6 +227,8 @@
        if (menu)
            return (*quote_func) (menu, 0);
        break;
+    case 's': if (!panel->marked)
+               return (*quote_func) (fname, 0);

        /* Fall through */

------------------------------------------


Comment 4 Jonathan Blandford 2001-07-13 19:40:52 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.