Bug 154862 - kickstart fails to install grub on previously unformatted partition
kickstart fails to install grub on previously unformatted partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 12:17 EDT by Anders Blomdell
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 17:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Blomdell 2005-04-14 12:17:27 EDT
Description of problem:

When kickstart installing on a (SATA) disk where the root partition has not
previously been formatted with mkfs.*, grub fails to install.

Version-Release number of selected component (if applicable):

FedoraCore 3

How reproducible:

Always

Steps to Reproduce:
1. Totally erase the disks (dd if=/dev/zero of=/dev/sda)
2. Repartition the disk
3. Do a kickstart install
  
Actual results:

The root filesystem is formatted as part of the kickstart installation, then
grub fails as follows:

grub> root (hd0,4)
File system type unknown, partition type 0x83
grub> install /boot/grub/stage1 d (hd0) /boot/grub/stage2 p (hd0,4)
/boot/grub/grub.conf
Error 17: Cannot mount selected partition

After rebooting, the system hangs.

Expected results:

A bootable system.  
  
Additional info:  

Rerunning kickstart solves the problem, since then grub correctly picks up the
filesystem type from the previous installation, so it seems like grub tries to
pick up the filesystem type from some location that is initialized at boot,
instead of reading it from the partition.
Comment 1 Jeremy Katz 2005-04-14 17:25:32 EDT
This should be fixed with post-fc3 grub.

Note You need to log in before you can comment on or make changes to this bug.