Bug 154867 - s-c-printer gives errors on install
s-c-printer gives errors on install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 12:40 EDT by Toshio Kuratomi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.142-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 08:54:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2005-04-14 12:40:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Description of problem:
When upgrading from FC3 to FC4t2, I run into bug #138493.  It appears that FC3 ran with python-2.3 and PyXML-0.8.3.  We need to upgrade to python-2.4 and PyXML-0.8.4 at the same time for s-c-printer to work.

Version-Release number of selected component (if applicable):
0.6.128-1

How reproducible:
Didn't try

Steps to Reproduce:
1. From an FC3 install with PyXML-0.8.3, upgrade system-config-printer and its _required_ dependencies.
2.
3.
  

Actual Results:    34:system-config-printer  ########################################### [ 36%]
Traceback (most recent call last):
  File "/usr/share/printconf/util/updateconf.py", line 29, in ?
    import printconf_conf as conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
ImportError: No module named utils

Expected Results:  Update with no errors.

Additional info:

I think the problem is s-c-printer still specifies PyXML-0.8.3 as it's minimum required version but it should require PyXML-0.8.4 instead.  Haven't tested this, but after reading bug #138493 I think the following will work::

From CVS:
--- printconf.spec      24 Mar 2005 18:12:39 -0000      1.36
+++ printconf.spec      14 Apr 2005 16:37:33 -0000
@@ -11,7 +11,7 @@
 BuildRequires: gettext, desktop-file-utils >= 0.2.92
 BuildRequires: cups-devel, python-devel, intltool
 PreReq: alchemist >= 1.0.33, python, python-abi = %{pyver}
-PreReq: perl, PyXML >= 0.8.3-2
+PreReq: perl, PyXML >= 0.8.4-1
 PreReq: fileutils, initscripts
 PreReq: rhpl >= 0.81
 Requires: m4, perl, pnm2ppa
Comment 1 Tim Waugh 2005-04-19 12:49:12 EDT
Please try 0.6.129-1.
Comment 2 Toshio Kuratomi 2005-04-19 14:55:43 EDT
Still gives errors. From system-config-printer built from today's CVS checkout::

# rpm -Uvh system-config-printer-0.6.129-1.i386.rpm
Preparing...                ########################################### [100%]
   1:system-config-printer  ########################################### [100%]
Traceback (most recent call last):
  File "/usr/share/printconf/util/updateconf.py", line 29, in ?
    import printconf_conf as conf
  File "/usr/share/printconf/util/printconf_conf.py", line 83, in ?
    from xml.utils import qp_xml
ImportError: No module named utils


Is there a reason
  PreReq: PyXML >= 0.8.4-1
as given in the previous patch snippet is wrong?  I tried another version with
that change made and things work as expected::

  -bash-3.00# rpm -Uvh system-config-printer-0.6.129-1.test.1.i386.rpm
  error: Failed dependencies:
        PyXML >= 0.8.4-1 is needed by system-config-printer-0.6.129-1.test.1.i386
  -bash-3.00# yum update PyXML
  ......
  -bash-3.00# rpm -Uvh system-config-printer-0.6.129-1.test.1.i386.rpm
  Preparing...                ########################################### [100%]
     1:system-config-printer  ########################################### [100%]
  -bash-3.00#
Comment 3 Tim Waugh 2005-04-20 04:26:07 EDT
Nothing more we can do at a package level, as far as I can see.
Comment 4 Tim Waugh 2005-04-20 04:26:19 EDT
Reassigning.
Comment 5 Toshio Kuratomi 2005-04-20 07:44:42 EDT
(In reply to comment #3)
> Nothing more we can do at a package level, as far as I can see.

In the current spec file the PreReq line is:
  PreReq: PyXML >= 0.8.3-2
I've tested that:
  PreReq: PyXML >= 0.8.4-1
does the expected thing.

If there's a reason not to do that, tell me.   Otherwise it seems like the
correct fix as it uses rpm's existing facilities for enforcing the requisite
update ordering.
Comment 6 Jeff Johnson 2005-08-26 22:52:43 EDT
Why is this assigned to rpm? I see no rpm problem described here ...
Comment 7 Tim Waugh 2005-09-05 08:05:29 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.