Bug 154930 - Bash auto-completion behavior has changed
Bash auto-completion behavior has changed
Status: CLOSED DUPLICATE of bug 155818
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bash (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2005-04-14 17:05 EDT by Patrice Guay
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-25 04:51:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 116135 None None None Never

  None (edit)
Description Patrice Guay 2005-04-14 17:05:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.6)
Gecko/20050318 Firefox/1.0.2

Description of problem:
The bash auto-completion mecanism has changed from RHEL3 to RHEL4. Bug #116135
describes the problem. Sometimes, hitting TAB is not enough to obtain
auto-completion. You need to press another key before completion is displayed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. find some folder with files which do have common prefix 
2. type a shorter prefix of that prefix 
3. press tab - nothing happens 
4. press any key - word is completed 

Actual Results:  bash auto-completion doesn't work as well as the version
shipped with RHEL3.

Expected Results:  bash auto-completion should always be done at step #3.

Additional info:

Bug #116135 states that this is the expected behavior. How do I get back to the
RHEL3 behavior?
Comment 1 Tim Waugh 2005-04-15 04:14:09 EDT
The behaviour has certainly not changed intentionally between Red Hat Enterprise
Linux 3 and 4, and the "steps to reproduce" you list above are confusing to me
-- were they copied from the bug report you reference?  Incidentally, that bug
report used the base version of bash that shipped in Red Hat Enterprise Linux 3,
which also indicates that this is not a regression from that product.

I have never seen the failure mode you describe, myself.  Is is really correct
that you press a key other than tab and suddenly (without again pressing tab)
the word is completed?  That would indeed be a bug.

What I get with a clean installation of Red Hat Enterprise Linux 4, following
your "steps to reproduce", is this:

3. The full common prefix is completed
4. The key I typed (x) appears after the common prefix.
Comment 2 Patrice Guay 2005-04-21 10:08:25 EDT
My RHEL4 installation is not "clean". The system was upgraded from a RHEL3
system with yum (which is not the recommended way, I know). I will try to
reproduce this behavior with a clean install.
Comment 3 Tim Waugh 2005-04-21 10:10:01 EDT
Comment 4 Patrice Guay 2005-04-23 20:31:53 EDT
After some verifications, I found this bug is specific to the konsole program. I
was not able to reproduce it under gnome-console and xterm. Bug #155818 was
filled which describes a way to reproduce the problem.
Comment 5 Tim Waugh 2005-04-25 04:51:45 EDT

*** This bug has been marked as a duplicate of 155818 ***

Note You need to log in before you can comment on or make changes to this bug.