Bug 154936 - Missing icons after update
Missing icons after update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
:
: 155004 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 17:38 EDT by Sigge Kotliar
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-13 05:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sigge Kotliar 2005-04-14 17:38:55 EDT
Description of problem:
Not sure if this is GTK2's fault, but I'll file it here.

After updating FC3 to FC4t2, a bunch of icons that are on buttons are missing,
being replaced by the "icon not found" icon. This is most noticeable in
Evolution, but many other apps have problems too, like Firefox.

In the evolution menu, all icons except "print", "delete" and "cancel" are broken.
In firefox, the "blank page" icon (the one near bookmarks) is broken, the
"bookmark folder" too, and the "secure page" icon is missing too. Of course,
there are many more missing icons, these are just examples. 

Kind of a major bug for those upgrading...
Comment 1 Matthias Clasen 2005-04-15 10:22:41 EDT
Does the problem persist after upgrading to gtk2-2.6.7-1 ?
Comment 2 Sigge Kotliar 2005-04-15 10:45:58 EDT
yes
Comment 3 Matthias Clasen 2005-04-15 11:00:18 EDT
Does running

for d in /usr/share/icons/*; do
  /usr/bin/gtk-update-icon-cache -f $d;
done

fix things ?
Comment 4 Sigge Kotliar 2005-04-15 11:04:45 EDT
No.

The output contains the following lines (many times and in apparently random order):

Failed to write cache file: Not a directory
Cache file created successfully.


Most files succeeded, but many failed.
Comment 5 Matthias Clasen 2005-04-15 13:09:02 EDT
hmm, I should have probably added some if [ -d $d]; to my snipplet

Comment 6 Sigge Kotliar 2005-04-15 13:13:45 EDT
How do you mean? Do you want me to run an other snippet? Please send me a
complete one if that is the case.
Comment 7 Matthias Clasen 2005-04-15 13:17:59 EDT
A complete snipplet that would run without errors is 

for d in /usr/share/icons/*; do
  if [ -d $d]; then
    /usr/bin/gtk-update-icon-cache -f $d;
  fi
done

but running that again will not change things, since the first run already
created caches where it made sense.

I can't think of much else other than that you probably still have 
gtk2-2.6.5 installed, which had icon problems. But those changes 
were completely reverted in 2.6.7.
Comment 8 Sigge Kotliar 2005-04-15 13:20:40 EDT
I did have problems removing 2.6.5, but I have now managed to do that, and
restarted gnome. 

See this:
[root@localhost sigge]# rpm -q gtk2
gtk2-2.6.7-1

Comment 9 Sigge Kotliar 2005-04-28 14:20:56 EDT
What's the news on this one?
Am I the only one getting this?
It's kind of a biggie, much of the functionality in evolution is gone when all
icons look broken, and I can't use the volume applet since the icon there is
entirely gone and not replaced by a "broken icon" icon.

This should be fixed before FC4 ships, or upgraders like me will be very unhappy ;-)

Let me know how I can help!
Cheers!
Comment 10 Matthias Clasen 2005-04-28 15:28:52 EDT
Well, upgrading is not technically supported, in particular not to or from test
releases. And yes, the rest of the rawhide-running world does not see this
particular problem any more, after upgrading to 2.6.7. 
Comment 11 Sigge Kotliar 2005-07-25 09:18:24 EDT
Looking at my past bug reports I found this.
I managed to "fix" this issue by removing the /usr/local/share/icons directory,
which had a bunch of icons probably installed by a make install long time ago.

I figured I'd mark this fixed, but perhaps there are some problems with having
icons in /usr/local that can be discovered through this?
Otherwise - just close the bug.

Sigge
Comment 12 Sigge Kotliar 2005-08-13 05:47:51 EDT
*** Bug 155004 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.