Bug 155014 - slocate package update overwrites /etc/updatedb.conf
Summary: slocate package update overwrites /etc/updatedb.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: slocate (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 17:58 UTC by James Laska
Modified: 2013-09-02 06:05 UTC (History)
1 user (show)

Fixed In Version: 2.7-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 09:13:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Laska 2005-04-15 17:58:00 UTC
# slocate-2.7-20

Since we have introduced DAILY_UPDATE=no in /etc/updatedb.conf I typically
toggle this to DAILY_UPDATE=yes.  I found after a rawhide update that my config
file change was replaced when a new package was installed (slocate-2.7-20). 
Does it make sense to set /etc/updatedb.conf as a %config(noreplace) file in the
slocate.spec?  This appears to be the process followed by other packages whose
config files live in /etc (e.g. bind).

[ slocate.spec from slocate-2.7-20 ]
%attr(644,root,root) %config /etc/updatedb.conf

[ proposed change to slocate.spec ]
%attr(644,root,root) %config(noreplace) /etc/updatedb.conf

Comment 1 Miloslav Trmač 2005-04-16 09:13:18 UTC
Good catch, thanks!

Fixed in slocate-2.7-21.


Note You need to log in before you can comment on or make changes to this bug.