Bug 155045 - acroread freezes window manager on select
acroread freezes window manager on select
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 155364 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 16:24 EDT by Christopher L. Conway
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 17:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher L. Conway 2005-04-15 16:24:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
Using Acrobat Reader 5.0.10, try to use the text or graphics select tool. The window manager immediately freezes. The mouse pointer works, but clicking doesn't have any effect. Switching to another terminal and killing the acroread process fixes the problem.

This is always reproducible.

Version-Release number of selected component (if applicable):
metacity-2.8.6-2

How reproducible:
Always

Steps to Reproduce:
1. Open a PDF using acroread
2. Select some text.
3. Press Ctrl-C or just click on the Edit menu.

Actual Results:  Window manager becomes unresponsive

Expected Results:  Text copied to clipboard

Additional info:
Comment 1 Ray Strode [halfline] 2005-04-15 17:13:30 EDT
Hi Christopher,

This is very likely a bug in the application and not Metacity.

Have you tried evince (http://www.gnome.org/projects/evince/)?  It is a new pdf
viewer that was written by some of the people here at Red Hat.  You might like it.
Comment 2 Ray Strode [halfline] 2005-04-19 14:48:19 EDT
*** Bug 155364 has been marked as a duplicate of this bug. ***
Comment 3 Christopher L. Conway 2005-04-19 16:57:13 EDT
Upgrading to a more recent version of acroread seems to fix the problem, but it
seemed to me allowing an application to freeze the WM is a bug in the WM (i.e.,
failing to prevent the freezing). I will give evince a test-driver. Thanks for
the tip.

Note You need to log in before you can comment on or make changes to this bug.