Bug 155049 - backtrace when attempting to 'add a shared resource to this service'
backtrace when attempting to 'add a shared resource to this service'
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 16:42 EDT by Corey Marthaler
Modified: 2009-04-16 16:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 16:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-04-15 16:42:27 EDT
Description of problem:
Traceback (most recent call last):
  File "/usr/share/system-config-cluster/ServiceController.py", line 158, in
on_add_shared
    self.populate_shared_tree()
  File "/usr/share/system-config-cluster/ServiceController.py", line 149, in
populate_shared_tree
    resources = resources_ptr.getChildren()
AttributeError: 'NoneType' object has no attribute 'getChildren'


Version-Release number of selected component (if applicable):
system-config-cluster-0.9.33-1.0.noarch.rpm
Comment 1 Jim Parsons 2005-04-26 08:20:16 EDT
This occurred because the conf file had no <resources> section. This condition
is handled in 0.9.36-1.0
Comment 2 Corey Marthaler 2005-04-26 16:29:42 EDT
fix verified in 0.9.36-1.0.

Note You need to log in before you can comment on or make changes to this bug.