Bug 155106 - Kernel paniced on shutdown
Kernel paniced on shutdown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-16 07:21 EDT by Russ Hammer
Modified: 2015-01-04 17:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russ Hammer 2005-04-16 07:21:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
while shuting down, I unplugged the USB mouse and the kernel paniced

Kernel panic - not syncing: drivers/block/cfg-iosched.c:1065: spin_is_locked on uninitialized spinlock c6bf801c (Not tainted)

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Didn't try


Additional info:
Comment 1 Dave Jones 2005-04-16 14:44:04 EDT
can I get lspci & lsmod output please ?
Comment 2 Russ Hammer 2005-04-16 18:51:10 EDT
[root@dhcp243 download]# lspci
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1251A
00:02.1 CardBus bridge: Texas Instruments PCI1251A
00:06.0 Multimedia audio controller: Cirrus Logic CS 4610/11 [CrystalClear
SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph
256AV] (rev 20)
06:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
[root@dhcp243 download]# lsmod
Module                  Size  Used by
parport_pc             28421  0
lp                     12489  0
parport                40201  2 parport_pc,lp
autofs4                26181  0
sunrpc                164485  1
pcmcia                 26465  4
dm_mod                 59221  0
md5                     4161  1
ipv6                  259201  14
xircom_cb              13633  0
yenta_socket           21065  3
rsrc_nonstatic         10433  1 yenta_socket
pcmcia_core            47993  3 pcmcia,yenta_socket,rsrc_nonstatic
uhci_hcd               33497  0
i2c_piix4               8657  0
i2c_core               21953  1 i2c_piix4
floppy                 64753  0
ext3                  131145  1
jbd                    82777  1 ext3
Comment 3 Dave Jones 2005-04-16 18:55:23 EDT
what does grep c6bf801c /proc/kallsyms say ?

I'm guessing this is the ide queue lock.  Alan, any ideas ?
Comment 4 Russ Hammer 2005-04-16 20:58:04 EDT
a "grep ^c6b /proc/kallsyms" is empty.   Sorry.
Comment 5 Alistair Riddoch 2005-04-19 19:56:54 EDT
My system panics in the same way very early during shutdown. The kernel panic
error message is exactly the same. It is 100% reproducible, ie it happens every
time the system is shutdown. Unlike the original reporter, I was not doing
anything with USB when it paniced. More info available on request.
Comment 6 Dmitry Butskoy 2005-04-21 08:13:59 EDT
  Similar issue.
  When I unplug USB flash, after several seconds the kernel (2.6.11-1.14_FC3)
panic with:
"Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on
 uninitialized spinlock d910c41c (Not tainted)"
  Note: it is not on shutdown -- during normal work. (Of couse, USB flash was
unmount before unplug).

  "grep d910c41c /proc/kallsyms" shows nothing too
  And it is not reproducible for a while...
Comment 7 Dmitry Butskoy 2005-04-21 08:14:44 EDT
  Similar issue.
  When I unplug USB flash, after several seconds the kernel (2.6.11-1.14_FC3)
panic with:
"Kernel panic - not syncing: drivers/block/cfq-iosched.c:1065: spin_is_locked on
 uninitialized spinlock d910c41c (Not tainted)"
  Note: it is not on shutdown -- during normal work. (Of couse, USB flash was
unmount before unplug).

  "grep d910c41c /proc/kallsyms" shows nothing too
  And it is not reproducible for a while...
Comment 8 Dave Jones 2005-04-21 13:16:52 EDT
can you try the test kernels at 
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/

and see if that solves it ?
Comment 9 Alistair Riddoch 2005-04-21 19:18:27 EDT
Your test kernel kernel-2.6.11-1.19_FC3 i586 non-smp has fixed the problem for
me. The system no longer panics on shutdown. During the brief period I have been
using the kernel for normal use I have noticed no other problems with it.

Good work Dave.
Comment 10 riki 2005-04-22 06:42:43 EDT
Similar issue (kernel 2.6.11-1.14_FC3 on AMD Athlon).
Kernel panic early on shutdown. It seems it happens only when I used a usb 
flash card during session (but unmounted and removed before the shutdown).
I haven't executed grep on /proc/kallsyms yet.
I will try your kernel asap.

Thanks
riki
Comment 11 Dave Jones 2005-07-15 16:44:52 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Dmitry Butskoy 2005-07-18 07:28:29 EDT
  All was OK since 2.6.11-1.27_FC3, and appropriate patch was committed upstream
(I see all needed changes in the newest kenrel-2.6.12 source).
  IMHO, this bug is yet another duplicate of bug 155472 ...

Note You need to log in before you can comment on or make changes to this bug.