Bug 155161 - grub keeps rebooting the pc on a clean install of fedora 3
grub keeps rebooting the pc on a clean install of fedora 3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-17 06:39 EDT by Ruwan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-18 22:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruwan 2005-04-17 06:39:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
HI

Im fairly new to linux. I recently purchased a new pc and tried to install the full package of fedora 3 on it. Its the first time I tried to install fedora on a pc running a SATA harddisk. Well the installation seems to go well. Everything installs and then im prompted to reboot the pc. Once having been rebooted the pc gets up to the bit where it tries to launch grub and then it reboots again and this just keeps happening. I installed grub on MBR of the harddisk. If there is any aditional info holler back.

 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Ruwan 2005-04-17 07:09:32 EDT
just a notice. BIOS detects my sata device. But when I set my boot device i 
just select hdd. Does it know im indicating my SATA device or is it expecting 
an IDE device. I tried installing XP before and it wouldnt see my SATA at all.
Comment 2 Sitsofe Wheeler 2005-04-17 17:43:44 EDT
Ruwan,

You are probably going to have to give some extra details about which hardware
you have...
Comment 3 Ruwan 2005-04-17 19:31:28 EDT
here is my hardware specs Gigabyte 8S661FXM-775 SIS, 3Mhz P4, 512M hyundai DDR, 
seagate 80g sata HD. The only other IDE device connected is my dvd rw drive.

I was searching the net and I found similar problems where the computer would 
reboot at grub stage 2. But some of these were resolved by re installing 
grub/modifying grub. I spent last night attempting to reinstall grub/ modify 
the grub.conf file. I thought it was a problem with mapping the partitions into 
grub. The only difference was grub now crashed at stage 1.5.

So i clean installed everything making a boot partition and running grub from 
there but that doesnt work either.

Im at work now but Ill post my grub.conf file up later if that would be of any 
assistance.
Comment 4 Ruwan 2005-04-17 19:47:31 EDT
this bug seems similar 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123611
but at the moment it doesnt help me.
Comment 5 Ruwan 2005-04-18 22:01:05 EDT
I managed to fix the boot partition problem by reinstalling grub from linux 
rescue. But I wanted to boot from the MBR so I reinstalled everything again and 
planned on doing the grub reinstall via linux rescue, but it turns out I didnt 
have to as this time it works perfect. Seems pretty strange!!??

well its fixed for me.

Note You need to log in before you can comment on or make changes to this bug.