Bug 155249 - kernel BUG at include/asm/spinlock.h:136!
kernel BUG at include/asm/spinlock.h:136!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-18 11:22 EDT by riki
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description riki 2005-04-18 11:22:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; it-IT; rv:1.7.6) Gecko/20050318 Firefox/1.0.2

Description of problem:
i was copying a disk partition using nc and dd
(server: nc -l -p 4000 > image, client: dd if=/dev/hda2 | nc server -p 4000)

during this operation the following messages appeared in /var/log/messages of the server machine (but the above copy completed successfully)

NOTE: this server actually is not SMP, is a single HT Pentium IV

Apr 18 16:13:54 fileserver kernel: ------------[ cut here ]------------
Apr 18 16:13:54 fileserver kernel: kernel BUG at include/asm/spinlock.h:136!
Apr 18 16:13:54 fileserver kernel: invalid operand: 0000 [#1]
Apr 18 16:13:54 fileserver kernel: SMP 
Apr 18 16:13:54 fileserver kernel: Modules linked in: nls_utf8 vfat fat usb_storage parport_pc lp parport md5 ipv6 autofs4 dm_mod video button battery ac uhc
i_hcd ehci_hcd i2c_i801 i2c_core e1000 floppy xfs exportfs raid1 ata_piix libata sd_mod scsi_mod
Apr 18 16:13:54 fileserver kernel: CPU:    0
Apr 18 16:13:54 fileserver kernel: EIP:    0060:[<c0300e44>]    Not tainted VLI
Apr 18 16:13:54 fileserver kernel: EFLAGS: 00010096   (2.6.11-1.14_FC3smp) 
Apr 18 16:13:54 fileserver kernel: EIP is at _spin_lock+0x36/0x40
Apr 18 16:13:54 fileserver kernel: eax: 0000000e   ebx: c159201c   ecx: c035878c   edx: 00000000
Apr 18 16:13:54 fileserver kernel: esi: cfb3f98c   edi: cde22678   ebp: cde22684   esp: cfdfaf94
Apr 18 16:13:54 fileserver kernel: ds: 007b   es: 007b   ss: 0068
Apr 18 16:13:54 fileserver kernel: Process pdflush (pid: 188, threadinfo=cfdfa000 task=cf816aa0)
Apr 18 16:13:55 fileserver kernel: Stack: c0317f5f c024c5be c6efcdf8 c024c5be 00000286 ce913af4 cf9e8d88 cf816aa0 
Apr 18 16:13:55 fileserver kernel:        00000000 00000000 c02454d7 cfdfa000 c0123e4f 00000000 c0145584 c0133e28 
Apr 18 16:13:55 fileserver kernel:        00000000 ffffffff c0133d96 00000000 00000000 00000000 c01022ff 00000000 
Apr 18 16:13:55 fileserver kernel: Call Trace:
Apr 18 16:13:55 fileserver kernel:  [<c024c5be>] cfq_exit_io_context+0x54/0xb3
Apr 18 16:13:55 fileserver kernel:  [<c024c5be>] cfq_exit_io_context+0x54/0xb3
Apr 18 16:13:55 fileserver kernel:  [<c02454d7>] exit_io_context+0x45/0x52
Apr 18 16:13:55 fileserver kernel:  [<c0123e4f>] do_exit+0x314/0x338
Apr 18 16:13:55 fileserver kernel:  [<c0145584>] pdflush+0x0/0x1e
Apr 18 16:13:55 fileserver kernel:  [<c0133e28>] kthread+0x92/0xb2
Apr 18 16:13:55 fileserver kernel:  [<c0133d96>] kthread+0x0/0xb2
Apr 18 16:13:55 fileserver kernel:  [<c01022ff>] kernel_thread+0x0/0x84
Apr 18 16:13:55 fileserver kernel: Code: ad de 75 13 f0 fe 0b 79 09 f3 90 80 3b 00 7e f9 eb f2 83 c4 08 5b c3 8b 44 24 0c c7 04 24 5f 7f 31 c0 89 44 24 04 e8
 5e 0a e2 ff <0f> 0b 88 00 14 77 31 c0 eb cf 81 78 04 ed 1e af de 75 0f f0 81 


Version-Release number of selected component (if applicable):
kernel 2.6.11-1.14_FC3smp

How reproducible:
Didn't try


Additional info:
Comment 1 James 2005-04-29 19:39:02 EDT
I've seen something similar with this kernel version.

eip: c024c5ed
------------[ cut here ]------------
kernel BUG at include/asm/spinlock.h:136!
invalid operand: 0000 [#1]
SMP 
Modules linked in: vfat fat radeon md5 ipv6 parport_pc lp parport autofs4 sunrpc
pcmcia ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables nls_utf8
ntfs(U) sd_mod dm_mod video button battery ac ohci1394 ieee1394 yenta_socket
rsrc_nonstatic pcmcia_core usb_storage scsi_mod ohci_hcd ehci_hcd
snd_atiixp_modem snd_atiixp snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd soundcore snd_page_alloc 8139too mii ext3 jbd
CPU:    0
EIP:    0060:[<c0300e44>]    Not tainted VLI
EFLAGS: 00010086   (2.6.11-1.14_FC3smp) 
EIP is at _spin_lock+0x36/0x40
eax: 0000000e   ebx: d843ec1c   ecx: c035878c   edx: 00000000
esi: de51a02c   edi: c164bd50   ebp: c164bd5c   esp: de962e60
ds: 007b   es: 007b   ss: 0068
Process gam_server (pid: 6164, threadinfo=de962000 task=cd3b9aa0)
Stack: c0317f5f c024c5ed c164b498 c024c5ed 00000296 d2519d64 c1643b68 cd3b9aa0 
       de962000 00000006 c02454d7 de962000 c0123e4f 00000006 d11c4178 c012aebf 
       00000000 de962f28 00000006 c1615e80 de962000 00000006 c0123ec8 00000006 
Call Trace:
 [<c024c5ed>] cfq_exit_io_context+0x83/0xb3
 [<c024c5ed>] cfq_exit_io_context+0x83/0xb3
 [<c02454d7>] exit_io_context+0x45/0x52
 [<c0123e4f>] do_exit+0x314/0x338
 [<c012aebf>] __dequeue_signal+0xe5/0x148
 [<c0123ec8>] do_group_exit+0x29/0x90
 [<c012c809>] get_signal_to_deliver+0x25d/0x36a
 [<c0103d36>] do_signal+0x5a/0x101
 [<c012afc1>] signal_wake_up+0x1e/0x32
 [<c012b45c>] specific_send_sig_info+0xa7/0xb6
 [<c02f9b75>] unix_release_sock+0x18f/0x257
 [<c015e6f8>] invalidate_inode_buffers+0xa/0x5d
 [<c0173a9d>] clear_inode+0x62/0x142
 [<c018ac5a>] dnotify_parent+0x1f/0x75
 [<c012c996>] sigprocmask+0x6c/0xc8
 [<c012ca3c>] sys_rt_sigprocmask+0x4a/0xc7
 [<c0103e14>] do_notify_resume+0x37/0x3b
 [<c0103f5a>] work_notifysig+0x13/0x15
Code: ad de 75 13 f0 fe 0b 79 09 f3 90 80 3b 00 7e f9 eb f2 83 c4 08 5b c3 8b 44
24 0c c7 04 24 5f 7f 31 c0 89 44 24 04 e8 5e 0a e2 ff <0f> 0b 88 00 14 77 31 c0
eb cf 81 78 04 ed 1e af de 75 0f f0 81 
 
Comment 2 Dave Jones 2005-05-01 03:55:16 EDT
can you give the test kernel at
http://people.redhat.com/davej/kernels/Fedora/FC3/ a try please ? This should be
going out to updates-testing in the next day or so.
Comment 3 James 2005-05-01 12:41:21 EDT
I've give it a whirl some time in the week if possible. For additional info, I'm
running a single P4 (no HyperThreading). Use the SMP kernel as the uniprocessor
builds don't appear to have IO-APIC support for uniprocessors (and I need this
for correct IRQ routing).
Comment 4 Dave Jones 2005-07-15 13:58:17 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.