Bug 15525 - linuxconf does not synchronize passwords with samba
Summary: linuxconf does not synchronize passwords with samba
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 22:49 UTC by mal
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mal 2000-08-05 22:49:59 UTC
linuxconf from RedHat 6.2 was synchronizing 
UNIX and SAMBA passwords.
linuxconf from RedHat 7.0 Beta does not do this 
any more and I did not find any settings for this.
This was an EXTREMELY CONVINIENT 
feature of linuxconf.
Please put UNIX and SAMBA passwords 
synchronization back.

Comment 1 mal 2000-08-18 23:38:45 UTC
Can this bug be fixed before the release?

Comment 2 Bill Nottingham 2000-08-19 22:24:58 UTC
I could be wrong, but I believe the samba configurator is
not included now (it has been known to eat config files.)

Comment 3 mal 2000-08-20 16:04:30 UTC
synchronization of passwords with samba was 
the only useable feature linuxconf samba configurator
(everything else was just too unreliable, at least in RedHat 6.2).

Without this synchronization it is much less convinient,
every time user added or password changed 
it will be necessary to type several shell commants like

mksmbpasswd.sh </etc/passwd | grep '^mal:' >>/etc/samba/smbpasswd
smbpasswd mal

is there a way to get this one feature back to linuxconf,
everything else is much less important.

Comment 4 Andrew Bartlett 2000-09-14 05:18:40 UTC
The pam_smbpass module can do this for all password changes - without the need
for linuxconf specfic changes.  (I use this on servers I manage and it works
very well).

You will need to add users to the smbpasswd file, and set the line 'password' in
the pam configuration file to 'optional' insted of 'required'

If redhat could do this then it would be VERY good.

Comment 5 Andrew Bartlett 2000-09-14 23:25:36 UTC
The only problem with the pam approach is that it will complain VERY loudly if
the account dosent exist in /etc/smbpasswd, so a little addition to adduser or
similar could polish off this as a *very* nice solution.

Comment 6 mal 2000-09-15 13:27:05 UTC
smbpasswd -a username
adds user "username" to smbpasswd file if the user 
is not already there. I think 
something equivalent this "-a" option can be done 
with pam_smbpass module.

Comment 7 Brent Fox 2002-06-05 16:18:14 UTC
Closing because we don't ship linuxconf anymore

Comment 8 Red Hat Bugzilla 2006-02-21 18:47:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.