Bug 155252 - mouse buttons do not work
mouse buttons do not work
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-04-18 12:20 EDT by Alain D D Williams
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-24 14:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alain D D Williams 2005-04-18 12:20:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Downloading the latest patches this morning and my mouse buttons no longer work, the mouse still moves round the screen but clicking any of the 3 buttons or rolling the wheel has no effect. Rebooting under the previous kernel (2.6.10-1.770_FC3) and the mouse works as normal/expected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot under 2.6.11-1.14_FC3
2. Run X or in standard 'console' mode, the mouse moves round the screen but clicking buttons does nothing.

Actual Results:  Clicks ineffective

Expected Results:  Cannot highlight/select text and cannot click on menus.

Additional info:

I have a laptop. The mousepad buttons still worked, the external mouse buttons did not. The external mouse is an AMU optical mouse 2050.

/etc/sysconfig/mouse  contains:
FULLNAME="Generic - 3 Button Mouse (PS/2)"

I ran mouseconfig and kudzu and it rewrote the file but with no change.
Comment 1 morgan read 2005-04-27 19:18:19 EDT
I can confirm this bug.
Just installed fc3 from fc2, updated to latest kernel (2.6.11-1.14_FC3 from
2.6.9-1.667) and the mouse buttons don't work, exactly as above.  Also running a
laptop and as above mousepad buttons still work.

[morgan@morgansmachine ~]$ cat /etc/sysconfig/mouse
FULLNAME="Generic - 3 Button Mouse (PS/2)"
[morgan@morgansmachine ~]$

Seems basic that pointing device works, maybe up-grade priority?
Comment 2 morgan read 2005-04-27 19:26:25 EDT
Oh yes,
The mouse: logitech; mod - M-C43; p/n 811401-0000
Comment 3 morgan read 2005-06-05 20:05:31 EDT
Still a bug with 2.6.11-1.27_FC3, same fix - 2.6.10
Comment 4 morgan read 2005-07-02 00:46:29 EDT
Still a bug with 2.6.11-1.35_FC3, same fix - 2.6.10
This is beginning to be a big problem - I'm wanting to move on to fc4, but with
this bug will I have a broken system if I do?...

Comment 5 Alain D D Williams 2005-07-02 04:07:48 EDT
I moved to FC4 this week (reinstall, not upgrade) and the mouse works nicely. If
Morgan finds the same thing if he upgrades then I don't know if it is worth
puzzling what was wrong with FC3.
Comment 6 Dave Jones 2005-07-15 15:27:26 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 morgan read 2005-07-15 23:17:29 EDT
Yes, fc3 fixed for kernel-2.6.12-1.1372_FC3.  Problem solved.
Following Alain's advice I have all my ducks lined up to go to fc4 any day now.
 From Alain's experience I don't expect there to be a problem, but if there is
I'll post - otherwise "solved".
Thanks very much for your help.
Comment 8 morgan read 2005-08-28 04:06:22 EDT
yup - solved in fc4 too.

Note You need to log in before you can comment on or make changes to this bug.