Bug 15526 - focus is sometimes wrong
Summary: focus is sometimes wrong
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 23:21 UTC by mal
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 22:16:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mal 2000-08-05 23:21:47 UTC
Sawfish often does not catch focus correctly.
Example:
Open netscape, open messanger and navigator.
Put navigator window above messanger window.

In navigatior window click:
Communicator ->Messanger.

As a result of this the messanger window will 
go on front (as it should be), but then it goes back again.

Comment 1 mal 2000-08-07 15:28:04 UTC
One more problem is when a "find" dialogue of netscape 
is open. It is often not possible to bring some 
window on top while "find" netscape dialogue is open.
No such problem with Enlightment.


Comment 2 Havoc Pennington 2000-08-07 15:56:41 UTC
The "one more problem" is fixed already (for future reference though, please
file separate problems as separate reports, if it wasn't fixed it would be hard
to keep track of).

Comment 3 Need Real Name 2000-11-02 22:16:28 UTC
This is an auto-raise misfeature. Popping the menu takes focus away from the
navigator window, when the menu is removed the focus is returned to the
navigator window, thus requeuing the auto-raise..

Comment 4 Havoc Pennington 2001-07-12 17:50:50 UTC
Works for me in latest rawhide


Note You need to log in before you can comment on or make changes to this bug.