Bug 155290 - Boot hangs on pcmcia ethernet card
Boot hangs on pcmcia ethernet card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-18 15:53 EDT by Warren Sturm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 13:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport from affected laptop booted to 2.6.10-1.770 (168.96 KB, application/octet-stream)
2005-04-28 00:21 EDT, Warren Sturm
no flags Details
debug log file from the boot of 2.6.10 and 2.6.11 kernels (162.89 KB, text/plain)
2005-05-18 01:26 EDT, Warren Sturm
no flags Details
3c589_cs.diff (7.22 KB, patch)
2005-06-13 12:11 EDT, John W. Linville
no flags Details | Diff

  None (edit)
Description Warren Sturm 2005-04-18 15:53:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The boot process hangs when the pcmcia card tries to activate.  There are about 30 errors of the type when the card is popped out:

eth0: command 0x5800 did not complete

The card is a combo ethernet/modem.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Always

Steps to Reproduce:
1.  Make sure pcmcia card (3C562D/3C563D in this case) is loaded
2.  boot system
3.


Actual Results:  system stops after starting sshd.  popping out the card will allow the boot process to continue.  Putting it back in and the system no longer responds

Expected Results:  Should have a working ethernet interface.  This setup does work with kernel-2.6.10-1.770_FC3.

Additional info:

hotplug-2004_04_01-8.1
pcmcia-cs-3.2.7-2.2
udev-039-10.FC3.7
Comment 1 John W. Linville 2005-04-27 11:32:18 EDT
Please attach the results of running "sysreport" on the box in question.  
Please run sysreport w/ the card in place, running the older kernel if 
necessary.  Thanks! 
Comment 2 Warren Sturm 2005-04-28 00:22:05 EDT
Created attachment 113757 [details]
sysreport from affected laptop booted to 2.6.10-1.770
Comment 3 John W. Linville 2005-05-13 10:38:21 EDT
Is it possible for you to try some other PCMCIA/CardBus network cards on this 
box?  If so, do the other cards work?  Or is this possibly a more general 
PCMCIA problem?  FWIW, I don't think there have been any changes to the 
network driver in question. 
Comment 4 Warren Sturm 2005-05-18 01:26:57 EDT
Created attachment 114495 [details]
debug log file from the boot of 2.6.10 and 2.6.11 kernels
Comment 5 Warren Sturm 2005-05-18 01:28:30 EDT
Got a slightly different result on a different laptop that has an integrated
ethernet controller.  The 2.6.10-1.770 version works ok, the 2.6.11-1.14 does
not.  I will include the debug file from the boots.  I will try to dig up a
wireless card, the only one I have is the Cisco Aironet (Atheros based) that
needs the madwifi driver.
Comment 6 Warren Sturm 2005-05-24 21:53:37 EDT
The same thing applies to 2.6.11-1.27
Comment 7 John W. Linville 2005-06-13 12:08:58 EDT
FWIW, there are relatively few changes to the driver between  
kernel-2.6.10-1.770_FC3 and kernel-2.6.11-1.14_FC3.  Those changes that are 
there are mostly just maintenance/janitor stuff accounting for changes in 
other kernel components.  I'll attach a diff below... 
Comment 8 John W. Linville 2005-06-13 12:11:36 EDT
Created attachment 115357 [details]
3c589_cs.diff
Comment 9 Dave Jones 2005-07-15 14:23:23 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Warren Sturm 2005-07-20 00:25:34 EDT
It is still there with the FC3 new kernel.  It does not seem to be a problem
with FC4 and a pcmcia wireless card (cisco aironet atheros based).  The wireless
card is a problem on the fc3 system.

Comment 11 John W. Linville 2005-08-18 13:52:58 EDT
Sounds like things are working in FC4... 

Note You need to log in before you can comment on or make changes to this bug.