Bug 155312 - need 32-bit /usr/lib/libxml2.a and .so
need 32-bit /usr/lib/libxml2.a and .so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-18 20:55 EDT by Konstantin Olchanski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.6.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 08:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2005-04-18 20:55:50 EDT
Description of problem:

We use an AMD64 machine running 64-bit Fedora 3 to build 32-bit-compatible
executables and we are missing the 32-bit /usr/lib/libxml2.a and .so.

This 32-bit library is in the i386 libxml2-devel package, but it cannot be
installed because of this error from RPM: "file /usr/bin/xml2-config from
install of libxml2-devel-2.6.16-3 conflicts with file from package
libxml2-devel-2.6.16-3". (This method works for e.g. "readline-devel").

A workaround is to: "ln -s /usr/lib/libxml2.so.2 /usr/lib/libxml2.so", but I do
not know if it works long-term- I have seen something (ldconfig?), sometimes,
remove and rearrange symlinks in /usr/lib.

In our environment, where we mostly build 32-bit binaries, we would prefer to
have all 32-bit development libraries installed by the "install everything"
install method.

For reference:
[olchansk@send src]$ rpm -q libxml2
libxml2-2.6.16-3
libxml2-2.6.16-3
[olchansk@send src]$ rpm -q libxml2-devel
libxml2-devel-2.6.16-3

K.O.
Comment 1 Daniel Veillard 2006-06-07 08:06:39 EDT
Should be fixed in rawhide with libxml2-2.6.26,

Daniel

Note You need to log in before you can comment on or make changes to this bug.