Bug 155340 - kernel BUG at spinlock:121
kernel BUG at spinlock:121
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-19 06:00 EDT by Jiri Kosina
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 20:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kosina 2005-04-19 06:00:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040819

Description of problem:
On our quite loaded disk server, which has attached hardware disk arrays (using aic7xxx SCSI driver) and serving clients through NFS, crashed with the following BUG in spinlock. It was running for ~14 days before hitting this BUG without crashing.

I can provide any additional info if desired.

Apr 18 21:34:19 storage4 kernel: eip: ffffffff80132a6d
Apr 18 21:34:19 storage4 kernel: ----------- [cut here ] --------- [please bite here ] ---------
Apr 18 21:34:19 storage4 kernel: Kernel BUG at spinlock:121
Apr 18 21:34:19 storage4 kernel: invalid operand: 0000 [1] SMP
Apr 18 21:34:19 storage4 kernel: CPU 1
Apr 18 21:34:19 storage4 kernel: Modules linked in: xfs nfsd exportfs lockd md5 ipv6 autofs4 sunrpc tg3 ohci_hcd video button battery ac ext3 jbd dm_mod aic7xxx sd_mod scs
Apr 18 21:34:19 storage4 kernel: Pid: 2764, comm: xfslogd/1 Not tainted 2.6.11-1.1191_FC4smp
Apr 18 21:34:19 storage4 kernel: RIP: 0010:[<ffffffff8035fa60>] <ffffffff8035fa60>{_spin_lock_irqsave+48}
Apr 18 21:34:19 storage4 kernel: RSP: 0018:ffff810079bc1d30  EFLAGS: 00010086
Apr 18 21:34:19 storage4 kernel: RAX: 0000000000000019 RBX: ffff810018fd13b0 RCX: ffffffff80430888
Apr 18 21:34:19 storage4 kernel: RDX: ffffffff80430888 RSI: 0000000000000082 RDI: ffffffff80430880
Apr 18 21:34:19 storage4 kernel: RBP: 0000000000000286 R08: ffff81003f53d248 R09: ffff8100000beae0
Apr 18 21:34:19 storage4 kernel: R10: 0000000000000001 R11: ffffffff8011d220 R12: 0000000000000000
Apr 18 21:34:19 storage4 kernel: R13: 0000000000000001 R14: 0000000000000292 R15: 0000000000000003
Apr 18 21:34:19 storage4 kernel: FS:  00002aaaaadb74c0(0000) GS:ffffffff80505100(0000) knlGS:00000000f7dbf080
Apr 18 21:34:19 storage4 kernel: CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
Apr 18 21:34:19 storage4 kernel: CR2: 00002aaaaaac0000 CR3: 000000007f0df000 CR4: 00000000000006a0
Apr 18 21:34:19 storage4 kernel: Process xfslogd/1 (pid: 2764, threadinfo ffff810079bc0000, task ffff81007941b170)
Apr 18 21:34:19 storage4 kernel: Stack: 0000000000000292 ffff810018fd13b0 ffff810079bc1d80 ffffffff80132a6d
Apr 18 21:34:19 storage4 kernel:        0000000000000000 0000000000000000 ffff81003f8854e8 ffff810031bb8728
Apr 18 21:34:19 storage4 kernel:        0000000000000292 ffffffff8821a750
Apr 18 21:34:19 storage4 kernel: Call Trace:<ffffffff80132a6d>{__wake_up+45} <ffffffff8821a750>{:xfs:pagebuf_iodone_work+0}
Apr 18 21:34:19 storage4 kernel:        <ffffffff8035f6ee>{__up_wakeup+53} <ffffffff881de4b0>{:xfs:xfs_buf_iodone_callbacks+0}
Apr 18 21:34:19 storage4 kernel:        <ffffffff881f7bb0>{:xfs:.text.lock.xfs_iget+25} <ffffffff881ddae6>{:xfs:xfs_buf_do_callbacks+38}
Apr 18 21:34:19 storage4 kernel:        <ffffffff881de5ee>{:xfs:xfs_buf_iodone_callbacks+318}
Apr 18 21:34:19 storage4 kernel:        <ffffffff8014c31c>{worker_thread+476} <ffffffff80134a10>{default_wake_function+0}
Apr 18 21:34:19 storage4 kernel:        <ffffffff80150ac0>{keventd_create_kthread+0} <ffffffff8014c140>{worker_thread+0}
Apr 18 21:34:19 storage4 kernel:        <ffffffff80150ac0>{keventd_create_kthread+0} <ffffffff80150d59>{kthread+217}
Apr 18 21:34:19 storage4 kernel:        <ffffffff80135f90>{schedule_tail+64} <ffffffff8010f6af>{child_rip+8}
Apr 18 21:34:19 storage4 kernel:        <ffffffff80150ac0>{keventd_create_kthread+0} <ffffffff8011d220>{flat_send_IPI_mask+0}
Apr 18 21:34:20 storage4 kernel:        <ffffffff80150c80>{kthread+0} <ffffffff8010f6a7>{child_rip+0}
Apr 18 21:34:20 storage4 kernel:
Apr 18 21:34:20 storage4 kernel:
Apr 18 21:34:20 storage4 kernel: Code: 0f 0b 0e e8 37 80 ff ff ff ff 79 00 f0 fe 0b 0f 88 3c 02 00
Apr 18 21:34:20 storage4 kernel: RIP <ffffffff8035fa60>{_spin_lock_irqsave+48} RSP <ffff810079bc1d30>


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1191_FC4smp

How reproducible:
Didn't try


Additional info:
Comment 1 Dave Jones 2005-04-19 20:51:12 EDT
that kernel is pretty ancient now (the amount of change since then is huge due
to a rebase to 2.6.11rc2).  I'd suggest updating anyway, but to be honest, I
don't recall anything XFS related that could fix this.

XFS gets little to no attention from Red Hat, so you'll likely get this fixed a
lot quicker by reporting it upstream.

Note You need to log in before you can comment on or make changes to this bug.