Bug 155353 - Firefox doesn't open MS Word documents in OpenOffice.org
Firefox doesn't open MS Word documents in OpenOffice.org
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-19 10:23 EDT by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 13:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2005-04-19 10:23:11 EDT
Description of problem:

I'm clicking on a link in our internal webmail solution and get a dialog saying
"You have chosen to open 'some long filename with spaces.doc' which is a: DOC
file from servername.domain.com. What should firefox do with this file"

And it suggests no handler for the file, just prompts to save it. This could
very well be a generic MIME problem, but then you can move it to the correct
product :-)

I tried the same on Windows in Internet Explorer and it worked ok there.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fridrich Strba 2005-05-20 04:18:45 EDT
This is a problem with the *.desktop file names missmatch between
openoffice.org-* packages and shared-mime-info package. Shared-mime-info is
expecting redhat-{word-processor,spreadsheet,presentations,drawing}.desktop, but
openoffice.org-* packages provide
openoffice.org-1.9-{base,calc,draw,impress,math,writer}.desktop. Since the
defaults are not present, the first application in alphabetical order that
supports the give mimetype is used. For every wordprocessing document, but the
oasis formats, gnome-abiword.desktop is used, since it is alphabetically before
openoffice.org-1.9*.desktop.
There are two possible solutions:
(1) in /usr/share/applications/defaults.list, replace the occurences
redhat-*.desktop with corresponding openoffice.org-1.9*.desktop;
(2) modify the openoffice.org packages the way that openoffice.org-1.9*.desktop
get renamed during the rpmbuild process in redhat-*.desktop and packaged as such.
Logically, I think that the second solution is the good one. I will ping caolanm
when he is back suggesting him a patch.
BTW: in shared-mime-info the application/vnd.wordperfect mimetype should be
handled by default by openoffice.org. Although using the same library as
abiword, the openoffice.org WordPerfect importer supports more features (correct
conversion of all tables, page form, orientation ...).
Comment 2 Dan Williams 2005-05-20 13:34:08 EDT
should be fixed in shared-mime-info-0.16-3 which should come out tomorrow

Solution is #1 after talking with jrb.  I also made OOo the default for
WordPerfect documents, as we Abiword is in Extras, not Core.

Note You need to log in before you can comment on or make changes to this bug.