Bug 155412 - mc hangs on files named with W32 codeset
mc hangs on files named with W32 codeset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-20 02:55 EDT by Fred
Modified: 2013-07-02 19:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 02:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred 2005-04-20 02:55:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
When trying to move, copy, delete or rename files which have the german unlaut characters in the file name, mc hangs at 95 - 100 % CPU.

The files were created under Windows 98 (I think), I'm not sure when or with which codeset. the characters are usually displayed as question marks, eg Gr?sse.doc.

The can be renamed from the command line using wildcards, and mc has no further problems with them after the renaming.



Version-Release number of selected component (if applicable):
mc-4.6.1-0.12.FC3

How reproducible:
Always

Steps to Reproduce:
1. start mc, navigate to a directory containing such a file
2. try to move, copy or delete the file
  

Actual Results:  mc hanged, and had to be manually killed


Expected Results:  the files should have been moved, copied or deleted.

Additional info:
Comment 1 Jindrich Novy 2005-04-20 04:32:39 EDT
Hello Fred,

I've done some fixes related to this issue in bug 150569 in devel branch. Could
you please test whether you can reproduce the issue also with devel version of mc?

I'll release FC3 update including this fix and additional fixes by Andrew V.
Samoilov if the issue is fixed by my tweak of mbstrlen().
Comment 2 Fred 2005-04-20 04:55:06 EDT
Hello Jindrich,

> I've done some fixes related to this issue in bug 150569 in devel branch.
> Could you please test whether you can reproduce the issue also with devel
> version of mc?

Sorry, I missed bug 150569, it must be the same or a similar problem.
I'd be happy to try the devel version, where do I get it ?
Comment 4 Fred 2005-04-20 06:59:20 EDT
thanks, the above rpm works for me
Comment 5 Jindrich Novy 2005-04-20 07:01:49 EDT
Fine, I'll release FC3 update then.

Thanks for testing,
Jindrich
Comment 6 Jindrich Novy 2005-04-21 02:27:12 EDT
The update is now released.

Note You need to log in before you can comment on or make changes to this bug.