Bug 155530 - X locks up the screen and keyboard on Ctrl+Alt+F7
X locks up the screen and keyboard on Ctrl+Alt+F7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 02:15 EDT by Bojan Smojver
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 21:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -vv output (5.74 KB, text/plain)
2005-04-21 02:15 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2005-04-21 02:15:37 EDT
Description of problem:

When the console is switched away from X and into the tty1 with Ctrl+Alt+F1, one
cannot go back to X with Ctrl+Alt+F7 on this particular hardware (I'll attach
lspci -vv later on). When Ctrl+Alt+F7 is pressed, the screen changes to a
somewhat garbled X session (i.e. it appears as if the session is there, but
there are garbled pixels at various places of the screen) and the keyboard and
screen lock up after that. One can SSH into the box fine.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13
kernel-2.6.11-1.14_FC3

How reproducible:
Always.


Steps to Reproduce:
1. Start X (GDM will do).
2. Go to tty1 by pressing Ctrl+Alt+F1.
3. Attempt to go back to X by pressing Ctrl+Alt+F7.
4. The screen and keyboard lock up.
  
Actual results:
Locks up.

Expected results:
Should work fine. And it did before X.org 6.8.2.

Additional info:
See attached lspci -vv. For hardware spec of this box go to:

http://www.rexursive.com/articles/linuxonhpze4201.html
Comment 1 Bojan Smojver 2005-04-21 02:15:38 EDT
Created attachment 113457 [details]
lspci -vv output
Comment 2 Bojan Smojver 2005-05-11 00:14:48 EDT
This is DRI related. Disabled DRI and everything works fine. I'm guessing the
latest radeon driver additions for DRI of IGP chips are causing this.
Comment 3 Mike A. Harris 2005-05-12 12:43:56 EDT
Attach X server log and config file from after the problem, as well
as output of lsmod, sysreport, and /var/log/messages as individual
file attachments.

Setting status to "NEEDINFO"
Comment 4 Bojan Smojver 2005-05-16 20:07:04 EDT
Just tried Fedora Core 4, Test 3 on this machine. DRI enabled, but no problem
any more. Just downloading devel updates (new kernel, new X) - hopefully it
remains fixed.

This is not fun anymore - all my bugs get fixed in new releases ;-)

I'll close once I confirm latest devel updates are fine too.
Comment 5 Mike A. Harris 2005-05-16 21:44:20 EDT
The X that's in Fedora Core 4, will eventually be released as an update
for Fedora Core 3.  I might even release one to fc3-testing based from
it soon, to get some test coverage there.

So if the problem is fixed in FC4 currently, I think it's safe to close
this as "RAWHIDE" for now, knowing it'll be fixed in a future FC3 update
also.

Thanks for the update.
Comment 6 Bojan Smojver 2005-05-16 22:43:50 EDT
Just checked with the latest X and kernel from devel - still good.

Note You need to log in before you can comment on or make changes to this bug.