Bug 15554 - pullnews doesn't work with Perl 5.6.0
Summary: pullnews doesn't work with Perl 5.6.0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-06 12:14 UTC by Jesper Skov
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 13:18:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesper Skov 2000-08-06 12:14:04 UTC
Moving from my RH62 box to a new installation of RH70b, I found that
pullnews (from inn) fails to run:

thinktwice:> pullnews
Connecting to downstream host localhost...Cant connect to server localhost

I tried different versions of the perl libnet code, but it didn't make
a difference. First when I uninstalled perl-5.6.0 and installed perl-5.0.04
from RH62 did pullnews start to work again.

I don't know whether this is a perl, perl-libnet, or an inn problem.

When pullnews tries to connect to port 119 under the new perl, the call
fails:

connect(3, {sin_family=AF_INET, sin_port=htons(119),
sin_addr=inet_addr("127.0.0
.1")}}, 16) = -1 EINPROGRESS (Operation now in progress)


It looks like this under the old perl:

connect(3, {sin_family=AF_INET, sin_port=htons(119),
sin_addr=inet_addr("127.0.0
.1")}}, 16) = 0

Comment 1 Nalin Dahyabhai 2000-08-07 12:08:11 UTC
Does this still happen with the latest builds?  A lot of networking stuff was
crapping out before Owen's fix for errno declarations got pulled in.

Comment 2 Jesper Skov 2000-08-07 12:14:18 UTC
Uh, dunno. This is from an installation from the public ISO images.

If you tell me which RPMs to update (and where to get them from - URL), I
can give it a try.

Jesper


Comment 3 Nalin Dahyabhai 2000-08-07 12:19:44 UTC
Try http://people.redhat.com/nalin/test/ in the short-term.

Comment 4 Jesper Skov 2000-08-07 13:18:50 UTC
This fixed the problem. Thanks!
Jesper



Note You need to log in before you can comment on or make changes to this bug.