Bug 155545 - Kickstart install hangs in the partitioning procedure
Kickstart install hangs in the partitioning procedure
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 06:57 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 17:11:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ANacdump.txt when a lvm partition scheme is defined in kickstart - fedora core 3 (63.01 KB, text/plain)
2005-12-22 16:15 EST, biju raman
no flags Details

  None (edit)
Description Need Real Name 2005-04-21 06:57:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

Description of problem:
While network installing FC3 in text mode with a kickstart file that was derived from a former manual install on the same hardware, the installation process hangs in the partitioning procedure

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start the computer via pxe in grub
2. load the kernel and initrd over the network with grub.conf item:
>>title Fedora Core 3 standaard
>>        root (nd)
>>        kernel /vmlinuz.fc3 ro text ks=http://installation.server.nl/fedora/core/3/i386/ks.cfg
>>        initrd /initrd.fc3

3. Installation runs autonomous until anaconda bug-report.
  

Actual Results:  Anaconda bug-report:
An unhandled exeption has occurred. This is 
most likely a bug. Please copy the full text
of this execption and file a detailed bug
report against anaconda at
http://bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1165, in ?
    intf.run(id, dispatch, configFileData)
  File :/usr/lib/anaconda/text.py", line 458,
in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line
276, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line
171, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/autopart.py", line
1416, in doAutoPartition
    doPartitioning(diskset, partitions,
doRefresh = 0)
  File "/usr/lib/anaconda/autopart.py", line
1003, in doPartitioning
    (ret, msg) = processPartitioing(diskset,
requests, newParts)
  File "/usr/lib/anaconda/autopart.py", line
953, in processPartitioning
    ret = fitSized(diskset, requests, 0,
newParts)
  File "/usr/lib/anaconda/autopart.py", line
361, in firSized
    requestSectors =
long((request.requestSize * 1024L * 1024L) /
part.disk.dev.sector_size) - 1
TypeError: unsupported operand type(s) for *:
'NoneType' and 'long'



Expected Results:  Completing the installation procedure and installing FC3

Additional info:

********************** ks.cfg **********************************
install
url --url http://installation.server.nl/fedora/core/3/i386/os
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
rootpw hallo
firewall --disabled
selinux --permissive
authconfig --enableshadow --enablemd5
timezone --utc Europe/Amsterdam
bootloader --location=mbr
clearpart --linux --initlabel
part /boot --fstype "ext3" --size=100
part pv.2 --size=0 --grow
volgroup VolGroup00 pv.2
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=256 --grow --maxsize=512

%packages

%post
********************** ks.cfg **********************************
Comment 1 Jeremy Katz 2005-04-21 11:43:53 EDT
Can you provide the complete anacdump.txt you received?
Comment 2 Need Real Name 2005-04-21 14:58:32 EDT
I made a typeover from the screen, that appeared and already attached it above
in the "Actual result" part.

If you need other info, please tell me where/how I can find it, than I will
reproduce the error and extract the info.

Koos.
Comment 3 Need Real Name 2005-04-21 15:15:13 EDT
I reproduced the installation but instead used the following kickstart file,
which differs in the way the partitioning is done:

*********************** ks.cfg *************************
install
url --url http://instalation.server.nl/fedora/core/3/i386/os
skipx
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
rootpw hallo
firewall --disabled
selinux --permissive
authconfig --enableshadow --enablemd5
timezone --utc Europe/Amsterdam
bootloader --location=mbr
clearpart --linux --initlabel
part /boot --fstype "ext3" --size=100
part / --fstype ext3 --size=1024 --grow
part swap --fstype swap --size=256 --grow --maxsize=512
reboot

%packages

%post
*********************** ks.cfg *************************

This instalation succeeded as expected. So I think kickstart is stumbling over
the Logvolume partitioning part.

Koos.
Comment 4 Need Real Name 2005-04-21 15:21:30 EDT
I reproduced this in FC4_test2.
I first installed FC4_test2 over the network. This went fine. Then I edited the
anaconda-ks.cfg file to look like this:
*********************** ks.cfg *************************
install
url --url http://installation.server.nl/fedora/core/4/i386/os
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
skipx
network --device eth0 --bootproto dhcp
rootpw hallo
firewall --disabled
selinux --permissive
authconfig --enableshadow --enablemd5
timezone --utc Europe/Amsterdam
bootloader --location=mbr
clearpart --all --drives=hda
part /boot --fstype ext3 --size=100 --initlabel
part pv.4 --size=0 --grow
volgroup VolGroup00 --pesize=32768 pv.4
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=256 --grow
--maxsize=512
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow

%packages

%post
*********************** ks.cfg *************************

With this ks.cfg I did a network install, that also brings anaconda to it's
knees with "install exited abnormally" "you may safely reboot your system"

Koos
Comment 5 Chris Lumens 2005-05-04 15:56:24 EDT
Please try again with fc4test3 or fc4 when available.  I have done some work in
this area in the past couple of days and may have fixed this problem.
Comment 6 Jeremy Katz 2005-09-21 17:11:59 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.
Comment 7 biju raman 2005-12-22 16:15:12 EST
Created attachment 122540 [details]
ANacdump.txt when a lvm partition scheme is defined in kickstart - fedora core 3

Hi Jeremy,

Please see the attached anacdump.txt. I was able to repeat this error each time
lvm partition definition is provided in kickstart along with "clearpart -all"
option. If "clearpart -all" is commented then anaconda declares that there is
not enough space on hard disk to create the required partitions. 

The same partition scheme can be generated if the definition is provided
interactively to Anaconda.

thanks
biju

Note You need to log in before you can comment on or make changes to this bug.