Bug 155581 - yum update fails after clean install
yum update fails after clean install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 12:00 EDT by Eric Warnke
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 13:54:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file (1.07 KB, text/plain)
2005-04-21 12:03 EDT, Eric Warnke
no flags Details
Session capture (299.00 KB, text/plain)
2005-04-21 12:06 EDT, Eric Warnke
no flags Details
Another session capture (40.34 KB, text/plain)
2005-04-21 15:38 EDT, Eric Warnke
no flags Details

  None (edit)
Description Eric Warnke 2005-04-21 12:00:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install minimal x86_64 box
2. yum update

  

Actual Results:  Yum will fail

Expected Results:  Yum should upgrade base install

Additional info:

Uploading kickstart file to show clean install and trace of commands run to show what I did to reproduce.  This is preventing us rolling out Fedora core to several new hosts.
Comment 1 Eric Warnke 2005-04-21 12:03:32 EDT
Created attachment 113476 [details]
Kickstart file

Attaching the very very basic kickstart file used.
Comment 2 Eric Warnke 2005-04-21 12:04:35 EDT
BTW 
Comment 3 Eric Warnke 2005-04-21 12:06:09 EDT
Created attachment 113477 [details]
Session capture

Attaching session capture, this captures the enture session ( editted to help
show breaks between commands ).
Comment 4 Eric Warnke 2005-04-21 12:12:00 EDT
To show nothing has been modified on the ISO's

halhead:/csminstall/Linux/Fedora/3/x86_64/ISO # md5sum *
b61b0eb7e0171837aeeff4f0054a4d79  FC3-x86_64-disc1.iso
99dc12c7e8a93844a48a5675a9c07ec9  FC3-x86_64-disc2.iso
399b7ffd721ebb4244a02c34cdbb1b82  FC3-x86_64-disc3.iso
f58b1de3b880df55dbbd37d143419226  FC3-x86_64-disc4.iso
Comment 5 Seth Vidal 2005-04-21 12:49:33 EDT
1. you don't have to post so much - you could start by just posting the errors.
2. you're hitting out-of-sync mirrors - hence the problem. if you're rolling out
a bunch of machines you may wish to consider setting up your own local mirror.

other than out-of-sync mirrors there's no error here.
Comment 6 Eric Warnke 2005-04-21 12:51:29 EDT
2) No, I can repeat this time and time again

yum update -> fails
yum --disablerepo=base update -> works

The reason I posted such a verbose logs was because I have been working through
all the other problems for the past day.
Comment 7 Eric Warnke 2005-04-21 12:52:16 EDT
I already have my own local mirror, but specifically did not use it to prevent
it being blamed on my local copy.
Comment 8 Eric Warnke 2005-04-21 15:38:01 EDT
Created attachment 113485 [details]
Another session capture

With the direction of someone else I tried several diffrent incarnations.  This
is from another pristine install.  As like before yum update fails.

Another bug highlighted here is the fact that yum SHOULD update itself before
it does anything.
Comment 9 Seth Vidal 2005-04-23 02:10:20 EDT
1. in the normal yum nightly update - you'll notice it DOES update itself first
- but not internally -it just runs a 'yum update yum' first.

2. updating yum before anything else on EVERY run of 'yum update' would be a
great deal more bothersome.

I'd say your workaround IS the fix.
Comment 10 Eric Warnke 2005-04-25 09:31:47 EDT
The base issue, x86_64 installs is still non-fulctional.

If you wish me to use a specific mirror to disprove your "bad mirror" please let
me know.
Comment 11 Seth Vidal 2005-04-25 09:48:49 EDT
Just use download.fedora.redhat.com and see if you can recreate the problem in #1.

However, and more to the point, there were some bugs in yum 2.1.11 - so updating
to the newer yum, FIRST, is useful for you.

Comment 12 Seth Vidal 2005-04-25 09:51:43 EDT
oh and if you had just enabled the yum cron job - the above would have been done
automatically.

Comment 13 Eric Warnke 2005-04-25 10:13:26 EDT
I do use the cron job, my nomal kickstart ends with 'chkconfig yum on', but that
is still not a proper solution to the problem and does not help during installation.

I am going to try again, this time using download.fedora.redhar.com and
executing the following steps.

1) yum update yum
2) yum update
3) yum --disablerepo=base update ( if the above fails )
Comment 14 Eric Warnke 2005-04-25 10:39:25 EDT
1) Booted another clean install ( with same kickstart )
2) went into /etc/yum.repos.d/fedora-updates.repo and commented out mirror list
and commented back in baseurl
3) yum update yum 
4) yum update <- Fails  identically to documentation
5) yum --disablerepo=base update <- works identically to documentation


Now will you believe me?
Comment 15 Seth Vidal 2005-04-25 23:20:34 EDT
It's not about belief it's about being able to recreate it and I have 2 problems:
1. you're the first one to report a problem like this for fc3
2. I can't replicate it.

please run:
yum list gcc\* cpp

and send the output.
Comment 16 Eric Warnke 2005-04-26 09:35:45 EDT
[root@dell5 ~]# yum list gcc\* cpp
Setting up Repos
base                      100% |=========================| 1.1 kB    00:00
updates-released          100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2852/2852
primary.xml.gz            100% |=========================| 375 kB    00:00
MD Read   : ################################################## 961/961
updates-re: ################################################## 961/961
Installed Packages
cpp.x86_64                               3.4.2-6.fc3            installed
Available Packages
cpp.x86_64                               3.4.3-22.fc3           updates-released
gcc.x86_64                               3.4.3-22.fc3           updates-released
gcc-c++.x86_64                           3.4.3-22.fc3           updates-released
gcc-debuginfo.x86_64                     3.4.3-22.fc3           updates-released
gcc-g77.x86_64                           3.4.3-22.fc3           updates-released
gcc-gnat.x86_64                          3.4.3-22.fc3           updates-released
gcc-java.x86_64                          3.4.3-22.fc3           updates-released
gcc-objc.x86_64                          3.4.3-22.fc3           updates-released
gcc4.x86_64                              4.0.0-0.41.fc3         updates-released
gcc4-c++.x86_64                          4.0.0-0.41.fc3         updates-released
gcc4-debuginfo.x86_64                    4.0.0-0.41.fc3         updates-released
gcc4-gfortran.x86_64                     4.0.0-0.41.fc3         updates-released


How are you attempting to recreate, since if your steps are diffrent they might
uncover the diffrence that is causing this problem.  If you need more
interactive ability to help track this down, please contact me ( AIM/ericew
YIM/curlyericw ) and we can either exchange text, or with a ssh pub key I can
get you access directly to the boxes in question.
Comment 17 Eric Warnke 2005-04-26 10:13:23 EDT
Another thing...

1) Clean install
2) Update yum
3) REMOVE CPP
Dependencies Resolved
Transaction Listing:
  Remove: cpp.x86_64 0:3.4.2-6.fc3
  Remove: kdebase.x86_64 6:3.3.0-8
  Remove: kdebase.i386 6:3.3.0-8
  Remove: kdemultimedia.i386 6:3.3.0-2
  Remove: xinitrc.noarch 0:4.0.14-1
  Remove: xorg-x11.x86_64 0:6.8.1-12
  Remove: xorg-x11-xdm.x86_64 0:6.8.1-12
Total download size: 0
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing: cpp 1/7
Erasing: kdebase 2/7
Erasing: xorg-x11 3/7
Erasing: kdemultimedia 4/7
Erasing: kdebase 5/7
Erasing: xinitrc 6/7
Erasing: xorg-x11-xdm 7/7

Removed: cpp.x86_64 0:3.4.2-6.fc3
Dependency Removed: kdebase.x86_64 6:3.3.0-8 kdebase.i386 6:3.3.0-8
kdemultimedia.i386 6:3.3.0-2 xinitrc.noarch 0:4.0.14-1 xorg-x11.x86_64
0:6.8.1-12 xorg-x11-xdm.x86_64 0:6.8.1-12

4) yum update: This is the interesting part.. 

Performing the following to resolve dependencies:
  Install: aqbanking.x86_64 0:1.0.4beta-0.fc3 - updates-released
  Install: cpp.x86_64 0:3.4.2-6.fc3 - base
  Install: glibc-devel.x86_64 0:2.3.5-0.fc3.1 - updates-released
  Install: glibc-headers.x86_64 0:2.3.5-0.fc3.1 - updates-released
  Install: glibc-kernheaders.x86_64 0:2.4-9.1.87 - base
  Install: gwenhywfar.x86_64 0:1.7.2-0.fc3 - updates-released
  Install: libofx.x86_64 0:0.7.0-0.fc3 - updates-released
Total download size: 245 M
Is this ok [y/N]:

Why is it not pulling cpp from updates?
Comment 18 Eric Warnke 2005-04-26 10:57:38 EDT
Also another quirk... I just ran through yum update a\* ... yum update z\* and
NONE of them pulled in cpp = 3.4.2?  Is the logic diffrent for update all as
opposed to update some when resolving dependancies? also another quirk... yum
update produces a totally diffrent output from yum update \*

Comment 19 Eric Warnke 2005-05-04 14:17:55 EDT
Even more broken now... they worked last week, but does not work this week.

yum -y update yum
yum -y --disablerepo=base update
yum -y update 

Fails with: Processing Dependency: libwmflite-0.2.so.7()(64bit) for package:
ImageMagick - Because libwmf is only in base. Oh and perl being screwed up and
being installed twice perl.i386 and perl.x86_64, and ends up: Transaction Check
Error:   file /usr/lib/perl5/5.8.5/File/Path.pm from install of
perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9, 

So now I'm up to 

yum -y update yum
yum -y install libwmf
yum -y remove perl.i386
yum -y --disablerepo=base update
yum -y update 

Just to get from clan system to completly updated system when only the first and
last command should be needed.
Comment 20 Seth Vidal 2005-05-05 02:48:00 EDT
the perl problem is a repository problem. The note about it was posted to
fedora-devel-list and I think fedora-announce.

Comment 21 Seth Vidal 2005-07-29 13:54:42 EDT
closing as this doesn't look like a yum bug but a repository problem.

reopen if you disagree.

Note You need to log in before you can comment on or make changes to this bug.