Bug 155618 - x86info gives "CPU Model: Unknown" on some P4 systems
x86info gives "CPU Model: Unknown" on some P4 systems
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-21 17:30 EDT by Stephen Walton
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 17:21:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Walton 2005-04-21 17:30:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
/usr/sbin/x86info on a Dell Precision 360 Workstation is returning:

x86info v1.11.  Dave Jones 2001, 2002
Feedback to <davej@suse.de>.

Found 1 CPU
Family: 15 Model: 3 Stepping: 4 Type: 0
CPU Model: Unknown CPU Original OEM
Processor name string:               Intel(R) Pentium(R) 4 CPU 2.80GHz

Processor serial: 0000-0F34-0000-0000-0000-0000
Number of logical processors supported within the physical package: 1


Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.7

How reproducible:
Always

Steps to Reproduce:
1. Run /usr/sbin/x86info

Actual Results:  Got CPU Model string as "Unknown CPU"

Expected Results:  CPU Model should be "Pentium 4".

Additional info:

x86info works fine on my Dell Precision 350 workstation.
Comment 1 Stephen Walton 2005-07-29 13:48:53 EDT
Update:  this problem is still present in version 1.13
Comment 2 Dave Jones 2005-09-23 17:52:02 EDT
can you try 1.15 from http://www.codemonkey.org.uk/projects/x86info/  ?

Comment 3 Stephen Walton 2005-09-26 16:01:50 EDT
Yes, 1.15 fixes the problem:

x86info v1.15.  Dave Jones 2001-2005
Feedback to <davej@redhat.com>.

Found 1 CPU
--------------------------------------------------------------------------
Found unknown cache descriptors: 64 81 91 96 112 124
Family: 15 Model: 3 Stepping: 4 Type: 0 Brand: 0
CPU Model: Pentium 4 (Prescott) [D0] Original OEM
Processor name string: Intel(R) Pentium(R) 4 CPU 2.80GHz

Feature flags:
 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflsh
ds acpi mmx fxsr sse sse2 ss ht tm pbe sse3 monitor ds-cpl cntx-id xTPR

Thanks!
Comment 6 RHEL Product and Program Management 2007-03-20 17:21:04 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.