This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 15566 - HP OmniBook 6000 reboot hangs system
HP OmniBook 6000 reboot hangs system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-06 11:45 EDT by Frank Sweetser
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Sweetser 2000-08-06 11:45:13 EDT
Try to do a shutdown -r now.  It goes through all of the init scripts, but when it tries to actually reset the machine, it just ends up locking the 
system up rock hard - pop-the-battery required.  shutdown -h now works perfectly, though, including powering the system off.
Comment 1 Glen Foster 2000-08-07 13:39:01 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 Frank Sweetser 2000-08-07 14:56:06 EDT
Appears to work under 2.2.17pre15 with same .config as stock RH kernel, minus
CONFIG_FB_ATY.
Comment 3 Michael K. Johnson 2000-08-17 16:27:47 EDT
BTW, pop-the-battery should not be required -- have you tried
holding down the power button for 4 seconds?
Comment 4 Michael K. Johnson 2000-08-17 16:33:19 EDT
CONFIG_FB_ATY=m; are you loading the module?
Comment 5 Frank Sweetser 2000-08-17 16:52:34 EDT
No, the power for several seconds doesn't seem to work, though now that I've
found it the magic keyhole in the side does =)

And no, doesn't look like the the related module is loaded - with the default
kernel I've got ds, i82365, pcmcia_core, lockd, sunrpc, 3c59x, agpgart,
usb-uhci, and usbcore loaded.
Comment 6 Michael K. Johnson 2000-08-17 17:04:29 EDT
So 2.2.17pre15 with CONFIG_FB_ATY=m still has the problem?
Comment 7 Frank Sweetser 2000-08-17 17:08:06 EDT
Sorry, should have been clearer - the 2.2.17pre's defaulted to CONFIG_FB_ATY=y. 
With this set, I couldn't even get a console at all.  So, I disabled it, and
found that I could reboot under the 17pre kernels fine.  I haven't tried with =m
yet as I assumed it wouldn't make a difference, but I could if you'd like.
Comment 8 Bill Nottingham 2000-08-18 11:28:41 EDT
Does (with the rc1 kernel) booting with:

linux init=/bin/bash

and then running

/sbin/reboot -f

work?
Comment 9 Frank Sweetser 2000-08-18 11:50:21 EDT
Yes, that reboots it fine.
Comment 10 Michael K. Johnson 2000-08-21 15:53:15 EDT
OK, I don't think that CONFIG_ATY_FB actually has anything
to do with the problem, probably a red herring.

Does it change anything if you chkconfig apmd off?
Comment 11 Frank Sweetser 2000-08-21 16:10:06 EDT
Nope, still hangs.
Comment 12 Frank Sweetser 2001-01-09 16:17:10 EST
Still present in 7.1 beta 2.
Comment 13 Frank Sweetser 2001-01-31 14:43:42 EST
7.1 beta 3.  Tried with reboot=warm, cold, bios, and hard, same results - hard
lockup.
Comment 14 Michael K. Johnson 2001-02-08 12:58:47 EST
How about apm=no -- does that change it?
Comment 15 Frank Sweetser 2001-02-08 13:30:10 EST
Nope - with apm=off ACPI fails to load, and it still locks up on reboot.  Also
tried with apm=off, no pcmcia, no apmd, same result.
Comment 16 Bugzilla owner 2004-09-30 11:38:48 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.