Bug 155724 - Shared libraries in apmd package without ldconfig calls in scriplets
Summary: Shared libraries in apmd package without ldconfig calls in scriplets
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: apmd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 15:21 UTC by Matthias Saou
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version: 3.2.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 16:25:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch (722 bytes, patch)
2005-04-22 15:21 UTC, Matthias Saou
no flags Details | Diff

Description Matthias Saou 2005-04-22 15:21:12 UTC
FC Dev apmd-3.2.2-2 installs shared libraries in /usr/lib but is missing calls
to /sbin/ldconfig in post/postun scriplets.
The quick patch below fixes this, and includes some other trivial corrections.

Come to think of it, a -devel sub-package could maybe be split off since the
main package contains a header file and a static library. I could submit a patch
for that too if desired.

Comment 1 Matthias Saou 2005-04-22 15:21:12 UTC
Created attachment 113562 [details]
Spec file patch

Comment 2 Bill Nottingham 2005-04-22 16:25:36 UTC
Fixed in -3 by removing the shared libraries entirely.


Note You need to log in before you can comment on or make changes to this bug.