Bug 155757 - konquest uses : as value of 10 for integers
Summary: konquest uses : as value of 10 for integers
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdegames   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 155767 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-22 19:55 UTC by Paul Dickson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-16 11:08:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2005-04-22 19:55:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050420 Firefox/1.0+

Description of problem:
In the game konquest, each planet produces a number of ships each turn.  The total is displayed when you mouse-over an owned planet.  Some times the total will have a : (colon) in the units digit (eg 13:).  The value of this colon is apparently 10, so 13: is 140.

This does not happen happen every time.  On a planet which increase the total by 10 each turn, every other turn will have a : in the total (in the units position).

This does not occur in the FC3 version of the game (kdegames-3.3.1-1).

This is a bad int-to-text routine somewhere (compiler?).

Version-Release number of selected component (if applicable):
kdegames-3.4.0-1

How reproducible:
Always

Steps to Reproduce:
1. Start new game.
2. Mouse-over your planet to get total.
3. Click "End Turn".
4. Perform 2 & 3 until turn 13.
5. Total should be 130, but 12: is displayed.
  

Actual Results:  On turn 13, the total should be 130, but 12: is displayed (if you did not move any ships).

Additional info:

With any luck, this bug is in konquest rather than the compiler.

Comment 1 Paul Dickson 2005-04-27 19:43:16 UTC
*** Bug 155767 has been marked as a duplicate of this bug. ***

Comment 2 Paul Dickson 2005-06-07 23:55:39 UTC
This problem has disappeared.  Likely from the replacement of glibc, but I not
sure of this fact.


Note You need to log in before you can comment on or make changes to this bug.