Bug 155814 - Need DocBook/XML 4.2 DTD support, or way to select same
Need DocBook/XML 4.2 DTD support, or way to select same
Product: Fedora
Classification: Fedora
Component: conglomerate (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phillip Compton
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-04-23 17:58 EDT by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-22 18:18:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2005-04-23 17:58:55 EDT
Description of problem:

Conglomerate provides a DocBook/XML 4.1.2 DTD, and the Fedora Documentation
Project globally uses 4.2.  Is it possible to either "update" the DTD somehow,
or give a user the option to change this (or add a DTD) with little or no hassle?

See also:

Version-Release number of selected component (if applicable):

How reproducible:
Every time, I think.

Steps to Reproduce:
1. Start new DocBook XML document.

Actual results:
DTD is 4.1.2.

Expected results:
DTD either 4.2, or allowing me to "upgrade."

Additional info:
Other than authoring in it, I am a DocBook idiot.  I don't know what the
difference is between 4.1.2 and 4.2, or whether it matters.  I don't know how to
make such a change in Conglomerate myself.  (I use Emacs.)  But I like how the
tool looks, and think this is an that needs to be in there -- if not now, then
eventually.  The Fedora Documentation Project is starting to kick up into
high(er) gear, and being able to eventually offer this tool in our toolchain
would make entry into the project easier for newbies.
Comment 1 Dave Malcolm 2005-09-09 19:59:15 EDT
Can you report this upstream please: bugzilla.gnome.org ?
Comment 2 Paul W. Frields 2005-12-22 18:18:57 EST
Seeing as how you can't yet most DocBook XML/4.1.2 docs we use into the tool,
adding more support may be premature.  I'm going to cancel this bug and will
revisit if and when conglomerate becomes more capable.

Note You need to log in before you can comment on or make changes to this bug.